media-video/cinelerra: Fix build with USE=-*; bug #606872.
authorAlexis Ballier <aballier@gentoo.org>
Mon, 23 Jan 2017 08:55:24 +0000 (09:55 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 23 Jan 2017 08:55:24 +0000 (09:55 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

media-video/cinelerra/cinelerra-20150908.ebuild
media-video/cinelerra/files/cinelerra-includes.patch [new file with mode: 0644]

index e31d0c4782ee3ce09099f0c705d96f7d5cb57dee..7dd447b31de97a20fda55684eb32c80a6ef79b03 100644 (file)
@@ -68,7 +68,8 @@ src_prepare() {
                "${FILESDIR}"/${PN}-libav9.patch \
                "${FILESDIR}"/${PN}-pngtoh.patch \
                "${FILESDIR}"/${PN}-putbits-gcc52.patch \
-               "${FILESDIR}"/${PN}-implicit_decls.patch
+               "${FILESDIR}"/${PN}-implicit_decls.patch \
+               "${FILESDIR}"/${PN}-includes.patch
 
        if has_version '>=media-video/ffmpeg-2' ; then
                epatch "${FILESDIR}"/${PN}-ffmpeg2.patch
diff --git a/media-video/cinelerra/files/cinelerra-includes.patch b/media-video/cinelerra/files/cinelerra-includes.patch
new file mode 100644 (file)
index 0000000..45ac200
--- /dev/null
@@ -0,0 +1,12 @@
+Index: CinelerraCV-2.3/cinelerra/audiodevice.C
+===================================================================
+--- CinelerraCV-2.3.orig/cinelerra/audiodevice.C
++++ CinelerraCV-2.3/cinelerra/audiodevice.C
+@@ -19,6 +19,7 @@
+  * 
+  */
++#include <cassert>
+ #ifdef HAVE_FIREWIRE
+ #include "audio1394.h"
+ #endif