dev-perl/Video-Frequencies: EAPI6 + tests
authorKent Fredric <kentnl@gentoo.org>
Tue, 20 Mar 2018 08:42:36 +0000 (21:42 +1300)
committerKent Fredric <kentnl@gentoo.org>
Tue, 20 Mar 2018 08:52:08 +0000 (21:52 +1300)
- EAPI6ify
- Add basic compile tests

Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-perl/Video-Frequencies/Video-Frequencies-0.03-r2.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Video-Frequencies/Video-Frequencies-0.03-r2.ebuild b/dev-perl/Video-Frequencies/Video-Frequencies-0.03-r2.ebuild
new file mode 100644 (file)
index 0000000..cc38e57
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit perl-module
+
+DESCRIPTION="Video Frequencies perl module, for use with ivtv-ptune"
+HOMEPAGE="http://ivtv.sourceforge.net"
+SRC_URI="mirror://sourceforge/ivtv/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_configure() {
+       export OPTIMIZE="$CFLAGS"
+       perl-module_src_configure
+}
+
+src_test() {
+       ebegin "Compile testing Video::Frequencies ${PV}"
+               perl -Mblib="${S}" -M"Video::Frequencies ${PV} ()" -e1
+       if ! eend $?; then
+               echo
+               eerror "One or more modules failed compile:";
+               eerror "  Video::Frequencies ${PV}"
+               die "Failing due to module compilation errors";
+       fi
+       perl-module_src_test
+}