x11-misc/screengrab: add version 2.0.0
authorJimi Huotari <chiitoo@gentoo.org>
Tue, 11 Feb 2020 06:57:36 +0000 (08:57 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Tue, 11 Feb 2020 22:46:34 +0000 (23:46 +0100)
Closes: https://bugs.gentoo.org/708984
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/14620
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
x11-misc/screengrab/Manifest
x11-misc/screengrab/screengrab-2.0.0.ebuild [new file with mode: 0644]

index ea8563f05d59712f9a591106ff1b9beed1ad55d7..6093c0880eb7a52b1de8f020a283210effc17eef 100644 (file)
@@ -1 +1,2 @@
 DIST screengrab-1.101.tar.xz 130248 BLAKE2B 0a81b80249322a8c6b4767b9bae70d43eaa41619927fdd799179d6dc9e15fe0cfb8ef50794890d9f9c84787bb88b447f84452b64f88e114aa3393466b1cf443c SHA512 f253c4015f9c9ae6b53bb4919c0301cc843b0d6f6ab0b8ad88befbd397004aa4838d5900d1af86ed348cbba45fa352ded5192d494bd738c2f2b314e9ad73fb13
+DIST screengrab-2.0.0.tar.xz 119296 BLAKE2B 0f3c55a78fb80569b4f42e63b9443018b7296c1b48ad4aa0af4270df19f939c44dbfc932731d6b16b0e15b6a735db333387e110ca221f88aab033ecb7b56cc96 SHA512 f08cd37489062d4b9c66278203b2fdd0298d1222e42e9240c5812779216289728f84a6567d7570ad3bf209834df4549acd9d31550c328f7785da6176b237d7e7
diff --git a/x11-misc/screengrab/screengrab-2.0.0.ebuild b/x11-misc/screengrab/screengrab-2.0.0.ebuild
new file mode 100644 (file)
index 0000000..40ab78e
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt application for getting screenshots"
+HOMEPAGE="https://lxqt.org/"
+SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+BDEPEND="dev-qt/linguist-tools:5"
+DEPEND="
+       >=dev-libs/libqtxdg-3.3.1
+       dev-qt/qtcore:5
+       dev-qt/qtdbus:5
+       dev-qt/qtgui:5
+       dev-qt/qtwidgets:5
+       dev-qt/qtx11extras:5
+       dev-qt/qtnetwork:5
+       kde-frameworks/kwindowsystem:5[X]
+       x11-libs/libxcb
+       x11-libs/libX11
+       x11-libs/libXfixes
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+}