dev-python/pastedeploy: 2.0.1 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 10 Apr 2019 00:50:10 +0000 (19:50 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 10 Apr 2019 05:07:08 +0000 (00:07 -0500)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/pastedeploy/Manifest
dev-python/pastedeploy/pastedeploy-2.0.1.ebuild [new file with mode: 0644]

index 23af4933ae350be1b502d19d985368a0314263f4..e15f56ba98336d389b67d748049c49af5632bbd6 100644 (file)
@@ -1,2 +1,3 @@
 DIST PasteDeploy-1.5.2.tar.gz 24006 BLAKE2B 1088d5cdafc80402b44c6c0e62829d1efe666d9ef8c84409125173ce927aecb8ed3ec4283b9821a42cc614d27e74e43e79407554fabfd79f6a913f9742532c72 SHA512 03147b2e735f4504b928066d35f46e7d19a49b85afc506b793fba69c8827a4d5b8185074bdd4a963ac392cc104f5a608d1db9a3538d7d3239da5febcbff4ccab
 DIST pastedeploy-1.5.2-r1.tar.gz 29528 BLAKE2B 0c36f24e51eb66b9a2176083d42726be5be8e7eb9b7d73972bcb5a2b0094beb1c88f3eea9ce94bfccaf688b6f5fdbf18e43e38694b91107a141ac0acf0576ed6 SHA512 5d9f648d4bddb4fa0b018f5e1c100d0899ff9e6a429a0a54aede69800fa13b7bb0d606ff454c516b36c3b056320bbda4581de9d57a154e71493a8bd6208fb3ce
+DIST pastedeploy-2.0.1.tar.gz 32215 BLAKE2B a398c54813fa990e3f12ba7c66615e3e84e848ce0dc57177f7f76114a544a11f89569ac85f16afb1ee392a08ad06eb6b4f0cc5aa3f328d154643c541fcafa7bd SHA512 be50c434765d5a913f9456527a72bd88e778e947b1db99ee4ea2f3325366038d941bdab6c826bd61f0c1eb1618395e6bca2081ac99b5ca50aa7120406d5f4ce3
diff --git a/dev-python/pastedeploy/pastedeploy-2.0.1.ebuild b/dev-python/pastedeploy/pastedeploy-2.0.1.ebuild
new file mode 100644 (file)
index 0000000..e9fbd81
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+MY_PN="PasteDeploy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Load, configure, and compose WSGI applications and servers"
+HOMEPAGE="https://pypi.org/project/PasteDeploy/"
+# pypi tarball does not include tests
+SRC_URI="https://github.com/Pylons/${PN}/archive/${PV}.tar.gz ->  ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc test"
+
+RDEPEND="dev-python/namespace-paste[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+       esetup.py test
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       use doc && dodoc docs/*.txt
+       find "${D}" -name '*.pth' -delete || die
+}