projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
538a65d
)
dev-python/pycparser: skip tests if cpp is not in PATH
author
Mike Gilbert
<floppym@gentoo.org>
Sun, 24 May 2020 19:39:37 +0000
(15:39 -0400)
committer
Mike Gilbert
<floppym@gentoo.org>
Sun, 24 May 2020 19:40:21 +0000
(15:40 -0400)
Bug: https://bugs.gentoo.org/719934
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
dev-python/pycparser/pycparser-2.20.ebuild
patch
|
blob
|
history
diff --git
a/dev-python/pycparser/pycparser-2.20.ebuild
b/dev-python/pycparser/pycparser-2.20.ebuild
index 4b222c379ee4ce9dd33c2fc2f4ad179f7b401050..12172c1c82ea5889258d8e6e5372e6b4ba055fea 100644
(file)
--- a/
dev-python/pycparser/pycparser-2.20.ebuild
+++ b/
dev-python/pycparser/pycparser-2.20.ebuild
@@
-41,6
+41,8
@@
python_compile() {
}
python_test() {
+ # Skip tests if cpp is not in PATH
+ type -P cpp >/dev/null || return 0
# change workdir to avoid '.' import
cd tests || die
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"