sci-libs/numkit: Initial import
authorAlexey Shvetsov <alexxy@gentoo.org>
Fri, 23 Aug 2019 13:14:12 +0000 (16:14 +0300)
committerAlexey Shvetsov <alexxy@gentoo.org>
Fri, 23 Aug 2019 13:18:02 +0000 (16:18 +0300)
Package-Manager: Portage-2.3.72, Repoman-2.3.17
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
sci-libs/numkit/Manifest [new file with mode: 0644]
sci-libs/numkit/metadata.xml [new file with mode: 0644]
sci-libs/numkit/numkit-1.1.2.ebuild [new file with mode: 0644]

diff --git a/sci-libs/numkit/Manifest b/sci-libs/numkit/Manifest
new file mode 100644 (file)
index 0000000..b11a25b
--- /dev/null
@@ -0,0 +1 @@
+DIST numkit-1.1.2.tar.gz 243442 BLAKE2B e5d1e4d85b7646acf47a1e332cbb08f849272ada30bcd65fc5995cd000683f802eb882603e4e7043b159d30ca73395988b83c1fc16d6303ea32731bfdea12db5 SHA512 694a56f64282bbbffed975eabeb2716ac924fbf47f5fb62934ba3b57e6415e5f4b079345fd4eee670990fbf7abe1f945b98472aba034d8c7ff259676da58c034
diff --git a/sci-libs/numkit/metadata.xml b/sci-libs/numkit/metadata.xml
new file mode 100644 (file)
index 0000000..f38dc92
--- /dev/null
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>alexxy@gentoo.org</email>
+    <name>Alexey Shvetsov</name>
+  </maintainer>
+  <maintainer type="project">
+    <email>sci-chemistry@gentoo.org</email>
+    <name>Gentoo Chemistry Project</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="github">Becksteinlab/numkit</remote-id>
+  </upstream>
+</pkgmetadata>
diff --git a/sci-libs/numkit/numkit-1.1.2.ebuild b/sci-libs/numkit/numkit-1.1.2.ebuild
new file mode 100644 (file)
index 0000000..51a5500
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+if [[ $PV = *9999* ]]; then
+       scm_eclass=git-r3
+       EGIT_REPO_URI="https://github.com/Becksteinlab/${PN}.git"
+       EGIT_BRANCH="develop"
+       SRC_URI=""
+       KEYWORDS=""
+else
+       scm_eclass=vcs-snapshot
+       SRC_URI="https://github.com/Becksteinlab/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+inherit eutils distutils-r1 ${scm_eclass}
+
+DESCRIPTION="Numerical first aid kit (with numpy/scipy)"
+HOMEPAGE="https://numkit.readthedocs.io"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+BDEPEND="
+       dev-python/six[${PYTHON_USEDEP}]
+       >=dev-python/numpy-1.9[${PYTHON_USEDEP}]
+       >=sci-libs/scipy-1.0[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"