net-misc/nextcloud-client: use xdg eclass
authorBernard Cafarelli <voyageur@gentoo.org>
Tue, 10 Dec 2019 21:32:14 +0000 (22:32 +0100)
committerBernard Cafarelli <voyageur@gentoo.org>
Tue, 10 Dec 2019 21:34:55 +0000 (22:34 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
net-misc/nextcloud-client/nextcloud-client-2.6.0.ebuild
net-misc/nextcloud-client/nextcloud-client-2.6.1.ebuild

index 6a82390c3c07e366f8ce4481c36d4680f5b11ff9..9b0d12160a76f6f115641816ed6a6a56bcf0fd96 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils xdg-utils
+inherit cmake-utils xdg
 
 DESCRIPTION="Desktop Syncing Client for Nextcloud"
 HOMEPAGE="https://github.com/nextcloud/desktop"
@@ -79,13 +79,9 @@ src_configure() {
 }
 
 pkg_postinst() {
+       xdg_pkg_postinst
        if ! use doc ; then
                elog "Documentation and man pages not installed"
                elog "Enable doc USE-flag to generate them"
        fi
-       xdg_icon_cache_update
-}
-
-pkg_postrm() {
-       xdg_icon_cache_update
 }
index 6a82390c3c07e366f8ce4481c36d4680f5b11ff9..9b0d12160a76f6f115641816ed6a6a56bcf0fd96 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils xdg-utils
+inherit cmake-utils xdg
 
 DESCRIPTION="Desktop Syncing Client for Nextcloud"
 HOMEPAGE="https://github.com/nextcloud/desktop"
@@ -79,13 +79,9 @@ src_configure() {
 }
 
 pkg_postinst() {
+       xdg_pkg_postinst
        if ! use doc ; then
                elog "Documentation and man pages not installed"
                elog "Enable doc USE-flag to generate them"
        fi
-       xdg_icon_cache_update
-}
-
-pkg_postrm() {
-       xdg_icon_cache_update
 }