dev-ml/logs: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Thu, 23 Feb 2017 08:14:58 +0000 (09:14 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 23 Feb 2017 09:15:49 +0000 (10:15 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ml/logs/Manifest [new file with mode: 0644]
dev-ml/logs/logs-0.6.2.ebuild [new file with mode: 0644]
dev-ml/logs/metadata.xml [new file with mode: 0644]

diff --git a/dev-ml/logs/Manifest b/dev-ml/logs/Manifest
new file mode 100644 (file)
index 0000000..976c4cd
--- /dev/null
@@ -0,0 +1 @@
+DIST logs-0.6.2.tbz 18558 SHA256 a320ef34eda51694be23f2a383d83f9ae6a8430fd0ef8cec1fa8c58be5b10bce SHA512 a669e373652bac6789626ad1d58e414c6d156c646bf0706c9d55b04151850113d45a5c28077707514d1a27d46fcc0f90b39b8652ce7a3980f79675e9874db8b4 WHIRLPOOL 0bccd2561d7a454018d67b651083cf82d9f866f40dc39f04f28219e3aea0fb0db43b0e7bb45ae00932e709ef600fdce56a1dc14935ca70d97ba94445f5a7a129
diff --git a/dev-ml/logs/logs-0.6.2.ebuild b/dev-ml/logs/logs-0.6.2.ebuild
new file mode 100644 (file)
index 0000000..6f93da3
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="Logging infrastructure for OCaml"
+HOMEPAGE="http://erratique.ch/software/logs https://github.com/dbuenzli/logs"
+SRC_URI="http://erratique.ch/software/logs/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="javascript fmt cli lwt test"
+
+RDEPEND="
+       dev-ml/result:=[ocamlopt]
+       dev-lang/ocaml:=[ocamlopt]
+       javascript? ( dev-ml/js_of_ocaml:= )
+       fmt? ( dev-ml/fmt:= )
+       cli? ( dev-ml/cmdliner:=[ocamlopt] )
+       lwt? ( dev-ml/lwt:= )
+"
+DEPEND="${RDEPEND}
+       dev-ml/opam
+       dev-ml/topkg
+       dev-ml/ocamlbuild
+       dev-ml/findlib
+       test? ( dev-ml/mtime )
+"
+
+src_compile() {
+       ocaml pkg/pkg.ml build \
+               --with-js_of_ocaml $(usex javascript true false) \
+               --with-fmt $(usex fmt true false) \
+               --with-cmdliner $(usex cli true false) \
+               --with-lwt $(usex fmt true false) \
+               --tests $(usex test true false) \
+               || die
+}
+
+src_test() {
+       ocaml pkg/pkg.ml test || die
+}
+
+src_install() {
+       opam-installer -i \
+               --prefix="${ED}/usr" \
+               --libdir="${D}/$(ocamlc -where)" \
+               --docdir="${ED}/usr/share/doc/${PF}" \
+               ${PN}.install || die
+       dodoc CHANGES.md README.md
+}
diff --git a/dev-ml/logs/metadata.xml b/dev-ml/logs/metadata.xml
new file mode 100644 (file)
index 0000000..af32ee7
--- /dev/null
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+       <email>ml@gentoo.org</email>
+       <name>Gentoo ML Project</name>
+</maintainer>
+  <use>
+         <flag name="cli">Enables the Logs_cli library that provides command line support for controlling Logs.</flag>
+         <flag name="fmt">Enables the Logs_fmt reporter.</flag>
+         <flag name="lwt">Enables the Logs_lwt library that provides Lwt logging functions.</flag>
+  </use>
+</pkgmetadata>