dev-python/precis-i18n: Add package, needed for net-im/gajim bump
authorAmadeusz Żołnowski <aidecoe@gentoo.org>
Tue, 31 Jul 2018 23:00:34 +0000 (00:00 +0100)
committerAmadeusz Żołnowski <aidecoe@gentoo.org>
Wed, 1 Aug 2018 21:01:48 +0000 (22:01 +0100)
Thanks to Alex <maniac@pzskc383.dp.ua> for initial version of the
ebuild.

Gentoo-Bug: 651616

dev-python/precis-i18n/Manifest [new file with mode: 0644]
dev-python/precis-i18n/metadata.xml [new file with mode: 0644]
dev-python/precis-i18n/precis-i18n-1.0.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/precis-i18n/Manifest b/dev-python/precis-i18n/Manifest
new file mode 100644 (file)
index 0000000..ba8ebfe
--- /dev/null
@@ -0,0 +1 @@
+DIST precis_i18n-1.0.0.tar.gz 61251 BLAKE2B 3f49f77ae4e6eea6ac1429a8de9b4ebe217d4d901edc223ee487d8a11bb45dc9e21a1e9fef9bd4478273ae721b5c02e4e2a7d2a3f28da281fcbdc17a12a1094e SHA512 9017852fdd2a066b8e31521bd39843f3b1f87259ce87e1567cfaa2b932b52b745ad84eb89b77a4c3ea0a04e513573655266b2cc73997e951268646da7a000e5d
diff --git a/dev-python/precis-i18n/metadata.xml b/dev-python/precis-i18n/metadata.xml
new file mode 100644 (file)
index 0000000..252b16c
--- /dev/null
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>aidecoe@gentoo.org</email>
+       </maintainer>
+       <longdescription lang="en">
+               PRECIS-i18n: Internationalized Usernames and Passwords
+
+               This module implements the PRECIS Framework as described in:
+
+               PRECIS Framework: Preparation, Enforcement, and Comparison of Internationalized Strings in Application Protocols (RFC 8264)
+               Preparation, Enforcement, and Comparison of Internationalized Strings Representing Usernames and Passwords (RFC 8265)
+               Preparation, Enforcement, and Comparison of Internationalized Strings Representing Nicknames (RFC 8266)
+       </longdescription>
+       <upstream>
+               <bugs-to>https://github.com/byllyfish/precis_i18n/issues</bugs-to>
+               <remote-id type="github">byllyfish/precis_i18n</remote-id>
+               <remote-id type="pypi">precis-i18n</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/precis-i18n/precis-i18n-1.0.0.ebuild b/dev-python/precis-i18n/precis-i18n-1.0.0.ebuild
new file mode 100644 (file)
index 0000000..64ef719
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Internationalized Usernames and Passwords"
+HOMEPAGE="https://pypi.python.org/pypi/precis-i18n"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/_}/${P/-/_}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+       esetup.py test
+}