dev-python/setuptools: Reenable tests
authorMichał Górny <mgorny@gentoo.org>
Thu, 28 May 2020 08:01:09 +0000 (10:01 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 28 May 2020 08:03:04 +0000 (10:03 +0200)
Closes: https://bugs.gentoo.org/725492
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/setuptools/setuptools-46.4.0-r1.ebuild

index 3e7d069b4f865658cf0cb4cfbca62105e3208524..07b818e2943adf38c46c41acaf9494297ddb6126 100644 (file)
@@ -21,14 +21,12 @@ RESTRICT="!test? ( test )"
 BDEPEND="
        app-arch/unzip
        test? (
-               $(python_gen_cond_dep '
-                       dev-python/mock[${PYTHON_USEDEP}]
-                       dev-python/pip[${PYTHON_USEDEP}]
-                       >=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
-                       dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
-                       dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
-                       dev-python/wheel[${PYTHON_USEDEP}]
-               ' python2_7 python3_{6,7,8} pypy3)
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/pip[${PYTHON_USEDEP}]
+               >=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
+               dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+               dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+               dev-python/wheel[${PYTHON_USEDEP}]
                $(python_gen_cond_dep '
                        dev-python/futures[${PYTHON_USEDEP}]
                ' -2)
@@ -65,11 +63,6 @@ python_prepare_all() {
 }
 
 python_test() {
-       if [[ ${EPYTHON} == python3.9 ]]; then
-               einfo "Tests are skipped on py3.9 due to unported deps"
-               return
-       fi
-
        distutils_install_for_testing
        # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
        # It tries to sandbox the test in a tempdir