dev-ros/ament_cmake_version: convert to python-any-r1
authorAlexis Ballier <aballier@gentoo.org>
Fri, 13 Dec 2019 12:24:54 +0000 (13:24 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 13 Dec 2019 13:53:19 +0000 (14:53 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/ament_cmake_version/ament_cmake_version-0.8.1.ebuild
dev-ros/ament_cmake_version/ament_cmake_version-9999.ebuild

index 771e21ca92e4e3818f7fb3c301bd379ebece319e..0de78e13568cf0cbab73db7115c5a130ca4fd093 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python{3_6,3_7} )
 
-inherit cmake-utils python-r1
+inherit cmake-utils python-any-r1
 
 ROS_PN="ament_cmake"
 if [ "${PV#9999}" != "${PV}" ] ; then
@@ -30,19 +30,12 @@ else
 fi
 IUSE=""
 
-DEPEND="
-       dev-ros/ament_cmake_core[${PYTHON_USEDEP}]
+RDEPEND="
+       dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+       $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
        ${PYTHON_DEPS}
 "
-RDEPEND="${DEPEND}"
-BDEPEND="${DEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_configure() {
-       # This is a build tool that does not install python-related files
-       # ... but we need to propagate the deps and use python3 to build it.
-       local pyimpl="${PYTHON_COMPAT[0]}"
-       python_export "${pyimpl}" EPYTHON PYTHON
-       python_wrapper_setup
-       cmake-utils_src_configure
-}
index 771e21ca92e4e3818f7fb3c301bd379ebece319e..0de78e13568cf0cbab73db7115c5a130ca4fd093 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python{3_6,3_7} )
 
-inherit cmake-utils python-r1
+inherit cmake-utils python-any-r1
 
 ROS_PN="ament_cmake"
 if [ "${PV#9999}" != "${PV}" ] ; then
@@ -30,19 +30,12 @@ else
 fi
 IUSE=""
 
-DEPEND="
-       dev-ros/ament_cmake_core[${PYTHON_USEDEP}]
+RDEPEND="
+       dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+       $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
        ${PYTHON_DEPS}
 "
-RDEPEND="${DEPEND}"
-BDEPEND="${DEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_configure() {
-       # This is a build tool that does not install python-related files
-       # ... but we need to propagate the deps and use python3 to build it.
-       local pyimpl="${PYTHON_COMPAT[0]}"
-       python_export "${pyimpl}" EPYTHON PYTHON
-       python_wrapper_setup
-       cmake-utils_src_configure
-}