version bump
authorMichael Sterrett <mr_bones_@gentoo.org>
Sat, 25 Sep 2004 12:56:48 +0000 (12:56 +0000)
committerMichael Sterrett <mr_bones_@gentoo.org>
Sat, 25 Sep 2004 12:56:48 +0000 (12:56 +0000)
games-strategy/crimson/ChangeLog
games-strategy/crimson/Manifest
games-strategy/crimson/crimson-0.4.4.ebuild [new file with mode: 0644]
games-strategy/crimson/files/digest-crimson-0.4.4 [new file with mode: 0644]

index 46087142dd76124a9a8443537afb813ceee6113e..ec17c51625985d42ffb2c7632e217ab12fcd6ce3 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for games-strategy/crimson
 # Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/crimson/ChangeLog,v 1.11 2004/08/28 20:10:45 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/crimson/ChangeLog,v 1.12 2004/09/25 12:56:48 mr_bones_ Exp $
+
+*crimson-0.4.4 (25 Sep 2004)
+
+  25 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org> +crimson-0.4.4.ebuild:
+  version bump
 
   28 Aug 2004; David Holm <dholm@gentoo.org> crimson-0.4.3.ebuild:
   Added to ~ppc.
index d9f5afcfeb31d44ef77555c93ab3cd0632783d7d..18767901bafacfed7403e16774a25d329a382818 100644 (file)
@@ -1,6 +1,8 @@
-MD5 2e45ac96d794cce52299c13367160078 ChangeLog 1703
+MD5 f849c904abcba0ae68ef882611a98324 ChangeLog 1831
 MD5 647a79ee9719227053b9519d2cbe308c crimson-0.4.2.ebuild 1197
-MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
 MD5 21b50b37e5e92742a44dba7867858f18 crimson-0.4.3.ebuild 1307
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 483c54f73356e84d3a5f5ea015caac23 crimson-0.4.4.ebuild 1311
 MD5 1a52415580d0384faf85d82960384432 files/digest-crimson-0.4.2 66
 MD5 30708cd5a52e2002d0f0a8999bb91dac files/digest-crimson-0.4.3 66
+MD5 efea70fda25abaf431eaa4fe853747f7 files/digest-crimson-0.4.4 66
diff --git a/games-strategy/crimson/crimson-0.4.4.ebuild b/games-strategy/crimson/crimson-0.4.4.ebuild
new file mode 100644 (file)
index 0000000..80b80ef
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/crimson/crimson-0.4.4.ebuild,v 1.1 2004/09/25 12:56:48 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Tactical war game in the tradition of Battle Isle"
+HOMEPAGE="http://crimson.seul.org/"
+SRC_URI="http://crimson.seul.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ~ppc"
+IUSE="zlib"
+
+DEPEND=">=media-libs/libsdl-1.1.5
+       >=media-libs/sdl-mixer-1.2.4
+       media-libs/sdl-ttf
+       dev-libs/libxslt
+       zlib? ( sys-libs/zlib )"
+
+src_compile() {
+       egamesconf \
+               --disable-dependency-tracking \
+               $(use_enable zlib) \
+               --enable-cfed \
+               --enable-bi2cf \
+               --enable-comet \
+               || die
+       emake || die "emake failed"
+}
+
+src_install() {
+       make \
+               DESTDIR="${D}" \
+               pixmapsdir="/usr/share/pixmaps" \
+               install || die "make install failed"
+       dodoc NEWS README* THANKS TODO
+       make_desktop_entry crimson "Crimson Fields" crimson.png
+       prepgamesdirs
+}
+
+pkg_postinst() {
+       games_pkg_postinst
+
+       echo
+       ewarn "Crimson Fields ${PV} is not save-game compatible with previous versions."
+       echo
+       einfo "If you have older save files and you wish to continue those games,"
+       einfo "you'll need to remerge the version with which you started"
+       einfo "those save-games."
+}
diff --git a/games-strategy/crimson/files/digest-crimson-0.4.4 b/games-strategy/crimson/files/digest-crimson-0.4.4
new file mode 100644 (file)
index 0000000..7a0e387
--- /dev/null
@@ -0,0 +1 @@
+MD5 e8a97c5dc3078b53fd000e638200ed24 crimson-0.4.4.tar.bz2 632080