dev-util/github-cli: fix live ebuild
authorMike Gilbert <floppym@gentoo.org>
Sun, 17 May 2020 16:47:28 +0000 (12:47 -0400)
committerMike Gilbert <floppym@gentoo.org>
Mon, 18 May 2020 15:47:24 +0000 (11:47 -0400)
Closes: https://github.com/gentoo/gentoo/pull/15851
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
dev-util/github-cli/github-cli-0.8.0.ebuild
dev-util/github-cli/github-cli-9999.ebuild

index ec3be96c343aea65a591bb120012443c51881f0b..61c48d3dee4c832e915a57efd3349f8ba5cca316 100644 (file)
@@ -276,7 +276,7 @@ RDEPEND=">=dev-vcs/git-1.7.3"
 BDEPEND=">=dev-lang/go-1.13"
 
 src_unpack() {
-       if has live "${PROPERTIES}"; then
+       if [[ ${PV} == *9999 ]]; then
                git-r3_src_unpack
                go-module_live_vendor
        else
@@ -285,7 +285,7 @@ src_unpack() {
 }
 
 src_compile() {
-       has live "${PROPERTIES}" || export GH_VERSION="v${PV}"
+       [[ ${PV} == *9999 ]] || export GH_VERSION="v${PV}"
        # Golang LDFLAGS are not the same as GCC/Binutils LDFLAGS
        unset LDFLAGS
        emake
index ec3be96c343aea65a591bb120012443c51881f0b..61c48d3dee4c832e915a57efd3349f8ba5cca316 100644 (file)
@@ -276,7 +276,7 @@ RDEPEND=">=dev-vcs/git-1.7.3"
 BDEPEND=">=dev-lang/go-1.13"
 
 src_unpack() {
-       if has live "${PROPERTIES}"; then
+       if [[ ${PV} == *9999 ]]; then
                git-r3_src_unpack
                go-module_live_vendor
        else
@@ -285,7 +285,7 @@ src_unpack() {
 }
 
 src_compile() {
-       has live "${PROPERTIES}" || export GH_VERSION="v${PV}"
+       [[ ${PV} == *9999 ]] || export GH_VERSION="v${PV}"
        # Golang LDFLAGS are not the same as GCC/Binutils LDFLAGS
        unset LDFLAGS
        emake