dev-ros/image_rotate: Backport upstream patch to build with gcc6.
authorAlexis Ballier <aballier@gentoo.org>
Mon, 23 Jan 2017 12:26:10 +0000 (13:26 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 23 Jan 2017 12:28:12 +0000 (13:28 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ros/image_rotate/files/gcc6.patch [new file with mode: 0644]
dev-ros/image_rotate/image_rotate-1.12.19.ebuild

diff --git a/dev-ros/image_rotate/files/gcc6.patch b/dev-ros/image_rotate/files/gcc6.patch
new file mode 100644 (file)
index 0000000..e0737b4
--- /dev/null
@@ -0,0 +1,34 @@
+commit 6c2d65452bd5fe62723988a1a570789921900d59
+Author: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+Date:   Fri Sep 30 15:39:47 2016 +0200
+
+    address gcc6 build error
+    
+    With gcc6, compiling fails with `stdlib.h: No such file or directory`,
+    as including '-isystem /usr/include' breaks with gcc6, cf.,
+    https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
+    
+    This commit addresses this issue for this package in the same way
+    it was addressed in various other ROS packages. A list of related
+    commits and pull requests is at:
+    
+      https://github.com/ros/rosdistro/issues/12783
+    
+    Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+
+diff --git a/image_rotate/CMakeLists.txt b/image_rotate/CMakeLists.txt
+index 04ba03b..75d8e77 100644
+--- a/image_rotate/CMakeLists.txt
++++ b/image_rotate/CMakeLists.txt
+@@ -12,10 +12,7 @@ find_package(OpenCV REQUIRED core imgproc)
+ find_package(Eigen REQUIRED)
+ # add the executable
+-include_directories(SYSTEM ${catkin_INCLUDE_DIRS}
+-                           ${EIGEN_INCLUDE_DIRS}
+-                           ${OpenCV_INCLUDE_DIRS}
+-)
++include_directories(${catkin_INCLUDE_DIRS} ${EIGEN_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS})
+ add_library(${PROJECT_NAME} SHARED src/nodelet/image_rotate_nodelet.cpp)
+ target_link_libraries(${PROJECT_NAME} ${catkin_LIBRARIES} ${OpenCV_LIBRARIES})
index 67b5cf58a8fc0e9391d5f39c00ffae8d66feea2d..0a83d54e705c51d19cf1638157f92f7e9d1c1df8 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -26,3 +26,4 @@ RDEPEND="
        dev-ros/tf2_geometry_msgs
 "
 DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gcc6.patch" )