net-dns/rbldnsd: drop the python-2.7 test suite.
authorMichael Orlitzky <mjo@gentoo.org>
Sat, 4 Apr 2020 14:16:49 +0000 (10:16 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Sat, 4 Apr 2020 14:22:18 +0000 (10:22 -0400)
The test suite for rbldnsd uses python-2.7 (only), and realistically
that's not going to change any time soon. This commit drops the test
suite from the ebuild so that the python team isn't blocked on me at
some later point. If upstream ever migrates the test suite to
python-3.x and makes a release, I can put it back easy enough.

Bug: https://bugs.gentoo.org/715180
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
net-dns/rbldnsd/rbldnsd-0.998b-r2.ebuild [moved from net-dns/rbldnsd/rbldnsd-0.998b-r1.ebuild with 70% similarity]

similarity index 70%
rename from net-dns/rbldnsd/rbldnsd-0.998b-r1.ebuild
rename to net-dns/rbldnsd/rbldnsd-0.998b-r2.ebuild
index c73e294de9e994b491ebeb1b61cd8543d6e42d88..a95bcde36f78549be0f56862394bb12ab30c72a7 100644 (file)
@@ -2,9 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python2_7 )
 
-inherit toolchain-funcs python-any-r1
+inherit toolchain-funcs
 
 DESCRIPTION="DNS server designed to serve blacklist zones"
 HOMEPAGE="https://rbldnsd.io/"
@@ -13,23 +12,18 @@ SRC_URI="https://github.com/spamhaus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~hppa ~sparc ~x86"
-IUSE="ipv6 test zlib"
-RESTRICT="!test? ( test )"
+IUSE="ipv6 zlib"
 
 RDEPEND="zlib? ( sys-libs/zlib )"
 DEPEND="${RDEPEND}"
 BDEPEND="
        acct-group/rbldns
        acct-user/rbldns
-       test? (
-               ${RDEPEND}
-               ${PYTHON_DEPS}
-               $(python_gen_any_dep 'dev-python/pydns:2[${PYTHON_USEDEP}]')
-       )"
+"
 
-PATCHES=(
-       "${FILESDIR}/rbldnsd-0.997a-robust-ipv6-test-support.patch"
-)
+# The test suite was dropped from the ebuild because it requires
+# python-2.7, and it will crash if you try to run it now.
+RESTRICT=test
 
 src_configure() {
        # The ./configure file is handwritten and doesn't support a `make
@@ -48,12 +42,6 @@ src_compile() {
                RANLIB="$(tc-getRANLIB)"
 }
 
-src_test() {
-       emake check \
-               CC="$(tc-getCC)" \
-               PYTHON="${PYTHON}"
-}
-
 src_install() {
        einstalldocs
        dosbin rbldnsd
@@ -63,7 +51,3 @@ src_install() {
        diropts -g rbldns -o rbldns -m 0750
        keepdir /var/db/rbldnsd
 }
-
-python_check_deps() {
-       ! use test || has_version "dev-python/pydns:2[${PYTHON_USEDEP}]"
-}