net-im/pidgin: Attempt to fix installation with gnome-base/gconf
authorLars Wendler <polynomial-c@gentoo.org>
Sat, 14 Mar 2020 23:07:17 +0000 (00:07 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Sat, 14 Mar 2020 23:07:46 +0000 (00:07 +0100)
Bug: https://bugs.gentoo.org/712454
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-im/pidgin/pidgin-2.13.0-r8.ebuild

index c29e0e696739bc2343ebeaeb727056cc3368e748..2f3544b9a15a1ab7e0d406de03fa29ca6ef87ac2 100644 (file)
@@ -6,7 +6,7 @@ EAPI=7
 GENTOO_DEPEND_ON_PERL=no
 PYTHON_COMPAT=( python3_{6,7,8} )
 
-inherit autotools flag-o-matic toolchain-funcs multilib perl-module python-single-r1 xdg
+inherit autotools gnome2-utils flag-o-matic toolchain-funcs multilib perl-module python-single-r1 xdg
 
 DESCRIPTION="GTK Instant Messenger client"
 HOMEPAGE="http://pidgin.im/"
@@ -246,6 +246,8 @@ src_configure() {
 }
 
 src_install() {
+       # setting this here because gnome2.eclass is not EAPI-7 ready
+       export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
        default
 
        if use gtk ; then
@@ -279,3 +281,20 @@ src_test() {
        # make default build logs slightly more useful
        emake check VERBOSE=1
 }
+
+pkg_preinst() {
+       gnome2_gconf_savelist
+       xdg_pkg_preinst
+}
+
+pkg_postinst() {
+       gnome2_gconf_install
+       gnome2_schemas_update
+       xdg_pkg_postinst
+}
+
+pkg_postrm() {
+       gnome2_gconf_uninstall
+       gnome2_schemas_update
+       xdg_pkg_postrm
+}