dev-python/networkx: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 09:09:20 +0000 (10:09 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 09:09:20 +0000 (10:09 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/networkx/Manifest
dev-python/networkx/networkx-2.2.ebuild [deleted file]

index dbf557d614ea706a52d6ff09a48caeea48977472..a5e05b0f2ba53d34207edad563fe8f98d797b557 100644 (file)
@@ -1,2 +1 @@
-DIST networkx-2.2.zip 1700336 BLAKE2B 8cd4bda4100d5da10864f3b08d5a7faa11399176cfe39691aef46234a3de71bb175a3ac0b179cce9971c1954d0fc13469e41d610191c7827f1212d0e9ef1e3aa SHA512 098e58c5f93c72c789e736102815e2f6388eb34147a674941519ef6f6d6452cc09b76d8523893418cb69df133e7623ea2c62fa51144f598f592ebce0e3e3ccbb
 DIST networkx-2.4.tar.gz 1462338 BLAKE2B 90fd7d249f3b022dd9c861dd023881fd241cba0515e2e9991516c278a40b92ee03663eb2b15bd584f179c066529df0587293f9c9a211e7c526addf77fdaf5cd6 SHA512 38eabef56e3667b7fa85206ae01a0a8f5c71bfa2f324bc2490c433cb973508a03955183a0c58ae40390f86d6a4741135cdb426c4c15e53e2f123072f0cac1b89
diff --git a/dev-python/networkx/networkx-2.2.ebuild b/dev-python/networkx/networkx-2.2.ebuild
deleted file mode 100644 (file)
index 34015c5..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Python tools to manipulate graphs and complex networks"
-HOMEPAGE="http://networkx.github.io/ https://github.com/networkx/networkx"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="examples extras pandas scipy test xml yaml"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="
-       test? ( extras pandas scipy xml yaml )"
-
-COMMON_DEPEND="
-       >=dev-python/matplotlib-2.2.2[${PYTHON_USEDEP}]
-       extras? (
-               >=dev-python/pydot-1.2.4[${PYTHON_USEDEP}]
-               >=dev-python/pygraphviz-1.5[${PYTHON_USEDEP}]
-               >=sci-libs/gdal-1.10.0[python,${PYTHON_USEDEP}]
-       )
-       pandas? ( >=dev-python/pandas-0.23.3[${PYTHON_USEDEP}] )
-       scipy? ( >=sci-libs/scipy-1.1.0[${PYTHON_USEDEP}] )
-       xml? ( >=dev-python/lxml-4.2.3[${PYTHON_USEDEP}] )
-       yaml? ( >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}] )"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/decorator-4.3.0[${PYTHON_USEDEP}]
-       ${COMMON_DEPEND}
-       test? (
-               dev-python/nose[${PYTHON_USEDEP}]
-       )"
-RDEPEND="
-       >=dev-python/decorator-4.3.0[${PYTHON_USEDEP}]
-       ${COMMON_DEPEND}
-       examples? (
-               dev-python/pyparsing[${PYTHON_USEDEP}]
-       )"
-
-PATCHES=(
-)
-
-python_test() {
-       virtx nosetests -vv
-}
-
-python_install_all() {
-       use examples && dodoc -r examples
-
-       distutils-r1_python_install_all
-}