dev-libs/libgit2: Remove unmaintained live ebuild
authorMichał Górny <mgorny@gentoo.org>
Fri, 21 Feb 2020 06:47:03 +0000 (07:47 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 21 Feb 2020 10:08:24 +0000 (11:08 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-libs/libgit2/libgit2-0.99.0.ebuild
dev-libs/libgit2/libgit2-9999.ebuild [deleted file]

index 23bd171e31062a36b9ef155daa1166d00fff318d..3abe4784a16c8587ba970702f3b3c2bc6add50cf 100644 (file)
@@ -6,19 +6,14 @@ EAPI=7
 PYTHON_COMPAT=( python3_{6,7} )
 inherit cmake python-any-r1
 
-if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
-       inherit git-r3
-else
-       SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~ppc-macos"
-fi
-
 DESCRIPTION="A linkable library for Git"
 HOMEPAGE="https://libgit2.org"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/${P/_/-}
 
 LICENSE="GPL-2-with-linking-exception"
-SLOT="0/28"
+SLOT="0/0.99"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~ppc-macos"
 IUSE="examples gssapi libressl +ssh test +threads trace"
 RESTRICT="!test? ( test )"
 
@@ -35,7 +30,11 @@ DEPEND="${RDEPEND}
        virtual/pkgconfig
 "
 
-S=${WORKDIR}/${P/_/-}
+src_prepare() {
+       cmake_src_prepare
+       # relying on forked http-parser to support some obscure URI form
+       sed -i -e '/empty_port/s:test:_&:' tests/network/urlparse.c || die
+}
 
 src_configure() {
        local mycmakeargs=(
diff --git a/dev-libs/libgit2/libgit2-9999.ebuild b/dev-libs/libgit2/libgit2-9999.ebuild
deleted file mode 100644 (file)
index 41394dc..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-inherit cmake-utils python-any-r1
-
-if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
-       inherit git-r3
-else
-       SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~ppc-macos"
-fi
-
-DESCRIPTION="A linkable library for Git"
-HOMEPAGE="https://libgit2.org"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0/28"
-IUSE="examples gssapi libressl +ssh test +threads trace"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       !libressl? ( dev-libs/openssl:0= )
-       libressl? ( dev-libs/libressl:0= )
-       sys-libs/zlib
-       net-libs/http-parser:=
-       gssapi? ( virtual/krb5 )
-       ssh? ( net-libs/libssh2 )
-"
-DEPEND="${RDEPEND}
-       ${PYTHON_DEPS}
-       virtual/pkgconfig
-"
-
-src_configure() {
-       local mycmakeargs=(
-               -DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
-               -DBUILD_CLAR=$(usex test)
-               -DENABLE_TRACE=$(usex trace)
-               -DUSE_GSSAPI=$(usex gssapi)
-               -DUSE_SSH=$(usex ssh)
-               -DTHREADSAFE=$(usex threads)
-       )
-       cmake-utils_src_configure
-}
-
-src_test() {
-       if [[ ${EUID} -eq 0 ]] ; then
-               # repo::iterator::fs_preserves_error fails if run as root
-               # since root can still access dirs with 0000 perms
-               ewarn "Skipping tests: non-root privileges are required for all tests to pass"
-       else
-               local TEST_VERBOSE=1
-               cmake-utils_src_test -R offline
-       fi
-}
-
-src_install() {
-       cmake-utils_src_install
-       dodoc docs/*.{md,txt}
-
-       if use examples ; then
-               find examples -name '.gitignore' -delete || die
-               dodoc -r examples
-               docompress -x /usr/share/doc/${PF}/examples
-       fi
-}