dev-python/scrypt: Revbump again to 0.8.13-r2, restore lost changes
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 20 Nov 2019 19:30:08 +0000 (11:30 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 20 Nov 2019 19:30:34 +0000 (11:30 -0800)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.79, Repoman-2.3.18
RepoMan-Options: --force
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/scrypt/scrypt-0.8.13-r2.ebuild [moved from dev-python/scrypt/scrypt-0.8.13-r1.ebuild with 66% similarity]

similarity index 66%
rename from dev-python/scrypt/scrypt-0.8.13-r1.ebuild
rename to dev-python/scrypt/scrypt-0.8.13-r2.ebuild
index b1de37480d918dfd35010c98528bb8b31ddbff3d..18e40a00438389891218207b40ba0e072efc6ec4 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
 
 inherit distutils-r1
 
@@ -12,14 +12,12 @@ HOMEPAGE="https://bitbucket.org/mhallin/py-scrypt/wiki/Home/"
 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="BSD-2"
-KEYWORDS="amd64 ~arm ~arm64 x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
 SLOT="0"
 IUSE="test doc"
 
 RDEPEND="dev-libs/openssl:0="
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 
-python_test() {
-       esetup.py test
-}
+distutils_enable_tests unittest