dev-python/urdf_parser_py: bump to 0.4.3
authorAlexis Ballier <aballier@gentoo.org>
Mon, 18 May 2020 14:24:00 +0000 (16:24 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 18 May 2020 15:18:15 +0000 (17:18 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-python/urdf_parser_py/Manifest
dev-python/urdf_parser_py/urdf_parser_py-0.4.3.ebuild [new file with mode: 0644]

index ba0b6c10032c4ed38a0cd7746760d3f890e1f554..54a008fdeaa43e02b7ea40850ca42ed807ae3b64 100644 (file)
@@ -1 +1,2 @@
 DIST urdf_parser_py-0.4.1.tar.gz 20017 BLAKE2B 805ad1f86b7d79963cc03070efccae3a44602bb309949bd5f3ac613e48e9f6cbae01ba8973e128d654e88c51f59647828a2360966664b5bb0b045116dcb61092 SHA512 08466a76e64cd46b1e9188aec039b8a0c20499c43be7c859d98c55f2d8d36305a76f780789a019dbd2e6badad90e9bd421dcd1bc82d3b8529fd08a9f9d5885f3
+DIST urdf_parser_py-0.4.3.tar.gz 21317 BLAKE2B 8ac3806ae2342dcef10adf952c0027c11d1241e4448b64a915acdcbb5145486c3d83bda344f2d2bd82fecae27f95ce223896e6762139f6ee7c5f687338ad631e SHA512 235f9648bbdcc57ae28e4029844dfbb4d7875b82849b24a76ee9f75391f5b93e7ead73b3f1f0216c17087017055364277e51bc03a09fa7901edee2fc7acd65aa
diff --git a/dev-python/urdf_parser_py/urdf_parser_py-0.4.3.ebuild b/dev-python/urdf_parser_py/urdf_parser_py-0.4.3.ebuild
new file mode 100644 (file)
index 0000000..445b2d1
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+inherit distutils-r1
+
+DESCRIPTION="URDF parser for Python"
+HOMEPAGE="http://wiki.ros.org/urdfdom_py"
+SRC_URI="https://github.com/ros/urdf_parser_py/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+       dev-python/pyyaml[${PYTHON_USEDEP}]
+       dev-python/lxml[${PYTHON_USEDEP}]
+       dev-python/catkin_pkg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       test? (
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+       )"
+BDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+       nosetests --with-coverage || die
+}