media-libs/libmpris2client: migrate to EAPI6
authorDenis Dupeyron <calchan@gentoo.org>
Mon, 27 Nov 2017 21:46:20 +0000 (21:46 +0000)
committerDenis Dupeyron <calchan@gentoo.org>
Mon, 27 Nov 2017 21:46:47 +0000 (21:46 +0000)
Package-Manager: Portage-2.3.13, Repoman-2.3.3

media-libs/libmpris2client/libmpris2client-0.1.0-r1.ebuild [new file with mode: 0644]

diff --git a/media-libs/libmpris2client/libmpris2client-0.1.0-r1.ebuild b/media-libs/libmpris2client/libmpris2client-0.1.0-r1.ebuild
new file mode 100644 (file)
index 0000000..0a29d00
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils
+
+DESCRIPTION="A library to control MPRIS2 compatible players"
+HOMEPAGE="https://github.com/matiasdelellis/libmpris2client"
+SRC_URI="https://github.com/matiasdelellis/${PN}/releases/download/V${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2
+       x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README TODO )
+
+src_install() {
+       default
+
+       find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}