app-text/sword: Add patch for building with GCC 6
authorChris Reffett <creffett@gentoo.org>
Tue, 25 Oct 2016 00:42:52 +0000 (20:42 -0400)
committerChris Reffett <creffett@gentoo.org>
Tue, 25 Oct 2016 00:43:51 +0000 (20:43 -0400)
Gentoo-Bug: 593818

Package-Manager: portage-2.3.2

app-text/sword/files/sword-1.7.4-gcc6.patch [new file with mode: 0644]
app-text/sword/sword-1.7.4.ebuild

diff --git a/app-text/sword/files/sword-1.7.4-gcc6.patch b/app-text/sword/files/sword-1.7.4-gcc6.patch
new file mode 100644 (file)
index 0000000..54c7967
--- /dev/null
@@ -0,0 +1,22 @@
+--- sword-1.7.4/configure.ac.old       2016-09-21 18:04:55.029088352 -0400
++++ sword-1.7.4/configure.ac   2016-09-21 18:05:37.870349308 -0400
+@@ -197,7 +197,7 @@
+ fi
+-AM_CXXFLAGS="$AM_CXXFLAGS -ftemplate-depth-25"
++AM_CXXFLAGS="$AM_CXXFLAGS"
+ if test x$enable_warnings = xyes; then
+   AM_CFLAGS="$AM_CFLAGS -Werror"
+--- sword-1.7.4/configure.old  2016-09-21 18:05:05.900008373 -0400
++++ sword-1.7.4/configure      2016-09-21 18:06:03.822112657 -0400
+@@ -16793,7 +16793,7 @@
+ fi
+-AM_CXXFLAGS="$AM_CXXFLAGS -ftemplate-depth-25"
++AM_CXXFLAGS="$AM_CXXFLAGS"
+ if test x$enable_warnings = xyes; then
+   AM_CFLAGS="$AM_CFLAGS -Werror"
index 1567283b4ed69507930caed110c3e9abc9911055..3943b6faa6ecca12073cfba06f10a0a50452c072 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -39,6 +39,7 @@ src_prepare() {
        [Install]
        DataPath=${EPREFIX}/usr/share/${PN}/
        EOF
+       epatch "${FILESDIR}/${PN}-1.7.4-gcc6.patch"
 }
 
 src_configure() {