sys-libs/libsemanage: update live ebuild
authorJason Zaman <perfinion@gentoo.org>
Thu, 23 Feb 2017 07:23:47 +0000 (15:23 +0800)
committerJason Zaman <perfinion@gentoo.org>
Thu, 23 Feb 2017 11:14:23 +0000 (19:14 +0800)
python libs and include dir are now properly detected so dont need to pass in
need to pass the path to libsepol.a

Package-Manager: portage-2.3.3

sys-libs/libsemanage/files/libsemanage-2.7-build-paths.patch
sys-libs/libsemanage/libsemanage-9999.ebuild

index 0069c96ebdd42392d4ffc33dfe8ff6ce53d8ecde..4c2ad0d9462ad01722f44e025f4fe99c25014553 100644 (file)
@@ -30,8 +30,8 @@ index ef25902..7aad334 100644
        $(RANLIB) $@
  
  $(LIBSO): $(LOBJS)
--      $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -lsepol -laudit -lselinux -lbz2 -lustr -L$(LIBDIR) -Wl,-soname,$(LIBSO),--version-script=libsemanage.map,-z,defs
-+      $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -lsepol -laudit -lselinux -lbz2 -lustr -Wl,-soname,$(LIBSO),--version-script=libsemanage.map,-z,defs
+-      $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -lsepol -laudit -lselinux -lbz2 -L$(LIBDIR) -Wl,-soname,$(LIBSO),--version-script=libsemanage.map,-z,defs
++      $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -lsepol -laudit -lselinux -lbz2 -Wl,-soname,$(LIBSO),--version-script=libsemanage.map,-z,defs
        ln -sf $@ $(TARGET)
  
  $(LIBPC): $(LIBPC).in ../VERSION
index 5fdf0a04c98885262ab6983b9973736a59c944e3..53094b8c6e86ec2ff85b9ce3655a8ab72bca058f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -88,8 +88,7 @@ multilib_src_compile() {
 
        if multilib_is_native_abi && use python; then
                building_py() {
-                       python_export PYTHON_INCLUDEDIR PYTHON_LIBPATH
-                       emake CC="$(tc-getCC)" PYINC="-I${PYTHON_INCLUDEDIR}" PYTHONLBIDIR="${PYTHON_LIBPATH}" PYPREFIX="${EPYTHON##*/}" "$@"
+                       emake "$@"
                }
                python_foreach_impl building_py swigify
                python_foreach_impl building_py pywrap
@@ -104,8 +103,11 @@ multilib_src_install() {
 
        if multilib_is_native_abi && use python; then
                installation_py() {
-                       emake DESTDIR="${ED}" LIBDIR="${ED}/usr/$(get_libdir)" \
-                               SHLIBDIR="${ED}/usr/$(get_libdir)" install-pywrap
+                       emake DESTDIR="${ED}" \
+                               LIBDIR="${ED}/usr/$(get_libdir)" \
+                               SHLIBDIR="${ED}/usr/$(get_libdir)" \
+                               LIBSEPOLA="${EPREFIX%/}/usr/$(get_libdir)/libsepol.a" \
+                               install-pywrap
                        python_optimize # bug 531638
                }
                python_foreach_impl installation_py