app-misc/jq-1.6-r3: output the testsuite log if tests fail (#675510)
authorPatrick McLean <patrick.mclean@sony.com>
Tue, 19 Nov 2019 02:04:25 +0000 (18:04 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Tue, 19 Nov 2019 02:04:41 +0000 (18:04 -0800)
Since I can't locally reproduce bug #675510, and the test suite doesn't
output the failure by default I am going to close the bug by now. If
someone can reproduce it, it should have the failures attached.

Closes: https://bugs.gentoo.org/675510
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
app-misc/jq/jq-1.6-r3.ebuild

index 65410969fe534142b8583242d14ea29d2eed22ed..e233ec8fa42ecbfd0424de8a861fb3251d0913fd 100644 (file)
@@ -60,6 +60,16 @@ src_configure() {
        econf "${econfargs[@]}"
 }
 
+src_test() {
+       if ! emake check; then
+               if [[ -r test-suite.log ]]; then
+                       eerror "Tests failed, outputting testsuite log"
+                       cat test-suite.log
+               fi
+               die "Tests failed"
+       fi
+}
+
 src_install() {
        local DOCS=( AUTHORS README.md )
        default