sys-cluster/torque: drop broken USE=drmaa, fix doc and econf warn
authorIan Stakenvicius <axs@gentoo.org>
Thu, 5 Mar 2020 19:15:56 +0000 (14:15 -0500)
committerIan Stakenvicius <axs@gentoo.org>
Thu, 5 Mar 2020 19:16:28 +0000 (14:16 -0500)
-Fixed the documentation link in pkg_postinst
-Dropped USE=drmaa as its broken and upstream hasn't done anything with
the code since torque-2
-Removed the --disable-geometry-request config option

Closes: https://bugs.gentoo.org/697124
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Ian Stakenvicius <axs@gentoo.org>
sys-cluster/torque/torque-6.0.4-r1.ebuild

index 456675c959f4d81f67c71ccb04eddc32e222a71f..6f18c0252662e85b8f8b30585f113620066cff71 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/adaptivecomputing/torque/archive/6a0b37f85c7d644e921
 LICENSE="torque-2.5"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="autorun cgroups cpusets +crypt doc drmaa kernel_linux libressl munge nvidia quickcommit server +syslog tk"
+IUSE="autorun cgroups cpusets +crypt doc kernel_linux libressl munge nvidia quickcommit server +syslog tk"
 
 DEPEND_COMMON="
        sys-libs/zlib
@@ -100,12 +100,11 @@ src_configure() {
                $(use_enable tk tcl-qstat) \
                $(use_enable syslog) \
                $(use_enable server) \
-               $(use_enable drmaa) \
+               --disable-drmaa \
                $(use_enable munge munge-auth) \
                $(use_enable nvidia nvidia-gpus) \
                $(usex crypt "--with-rcp=scp" "--with-rcp=mom_rcp") \
                $(usex kernel_linux $(use_enable cpusets cpuset) --disable-cpuset) \
-               $(usex kernel_linux $(use_enable cpusets geometry-request) --disable-geometry-request) \
                $(usex kernel_linux $(use_enable cgroups) --disable-cgroups) \
                $(use_enable autorun) \
                $(use_enable quickcommit) \
@@ -113,6 +112,7 @@ src_configure() {
                --with-environ=/etc/pbs_environment \
                --with-default-server=${PBS_SERVER_NAME} \
                --disable-gcc-warnings \
+               --disable-silent-rules \
                --with-tcp-retry-limit=2 \
                --without-loadlibfile
 }
@@ -174,6 +174,6 @@ pkg_postinst() {
        if [[ -z "${REPLACING_VERSIONS}" ]] ; then
                elog "If this is the first time torque has been installed, then you are not"
                elog "ready to start the server.  Please refer to the documentation located at:"
-               elog "http://docs.adaptivecomputing.com/torque/${PN//./-}/adminGuide/help.htm#topics/torque/1-installConfig/initializeConfigOnServer.htm"
+               elog "http://docs.adaptivecomputing.com/torque/${PV//./-}/adminGuide/torquehelp.htm#topics/torque/1-installConfig/initializeConfigOnServer.htm"
        fi
 }