strip trailing whitespace
authorMike Frysinger <vapier@gentoo.org>
Thu, 22 Nov 2012 17:42:42 +0000 (12:42 -0500)
committerMike Frysinger <vapier@gentoo.org>
Thu, 22 Nov 2012 17:42:42 +0000 (12:42 -0500)
No functional changes here.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
bin/archive-conf
bin/ebuild-helpers/dodoc
bin/ebuild-helpers/doinfo
bin/ebuild-helpers/prepman
bin/egencache
bin/emerge-webrsync
bin/glsa-check
bin/misc-functions.sh
bin/repoman

index af34db6283d9b841bdc121f167cba30c0d964335..80fa308a1a025d44b84bff4b7f8f4364bcb75a13 100755 (executable)
@@ -35,7 +35,7 @@ except ImportError:
         for ix in range(len(md5sum)):
             hexform = hexform + "%02x" % ord(md5sum[ix])
         return hexform.lower()
-    
+
     def perform_checksum(filename):
         f = open(filename, 'rb')
         blocksize=32768
index c551735eb5340c19d40e7ee00e3a1bde3df67141..99122c4434cd05dd63d1d3cffa11daed3be5f33d 100755 (executable)
@@ -13,7 +13,7 @@ fi
 
 if [ $# -lt 1 ] ; then
        __helpers_die "${0##*/}: at least one argument needed"
-       exit 1  
+       exit 1
 fi
 
 if ! ___eapi_has_prefix_variables; then
index 355047f73068b8bf7293ab42f181931b5eca6095..2edbdc592e14db9f97468d12573cb2b541935153 100755 (executable)
@@ -6,7 +6,7 @@ source "${PORTAGE_BIN_PATH:-/usr/lib/portage/bin}"/isolated-functions.sh
 
 if [[ -z $1 ]] ; then
        __helpers_die "${0##*/}: at least one argument needed"
-       exit 1  
+       exit 1
 fi
 
 if ! ___eapi_has_prefix_variables; then
index 142d40443a46dccd41bf0eadb421a152c51e35e8..55a9483e3ff2890aced252990cf220357d250c1b 100755 (executable)
@@ -8,7 +8,7 @@ if ! ___eapi_has_prefix_variables; then
        ED=${D}
 fi
 
-if [[ -z $1 ]] ; then 
+if [[ -z $1 ]] ; then
        mandir="${ED}usr/share/man"
 else
        mandir="${ED}$1/man"
index 9d88237a31d09bce7c8a1e7ab6d35af7c5230079..8870d99942775a5f04709030f5868609b6cf7789 100755 (executable)
@@ -474,7 +474,7 @@ class GenUseLocalDesc(object):
                self._portdb = portdb
                self._output = output
                self._preserve_comments = preserve_comments
-       
+
        def run(self):
                repo_path = self._portdb.porttrees[0]
                ops = {'<':0, '<=':1, '=':2, '>=':3, '>':4}
index e826ec44065a404448e0659ada84592c31bc763c..76d31f51cc9b5a13b1de4afca7ba4f57684f4362 100755 (executable)
@@ -429,7 +429,7 @@ do_latest_snapshot() {
 usage() {
        cat <<-EOF
        Usage: $0 [options]
-       
+
        Options:
          --revert=yyyymmdd   Revert to snapshot
          -k, --keep          Keep snapshots in DISTDIR (don't delete)
index bfae0f997c8fa9fd4118f8b467918fd1777dd79d..b3eb14689cd63d12ef21e503c68b3af3d1fc6c9f 100755 (executable)
@@ -114,7 +114,7 @@ glsalist = []
 if "new" in params:
        glsalist = todolist
        params.remove("new")
-       
+
 if "all" in params:
        glsalist = completelist
        params.remove("all")
@@ -183,7 +183,7 @@ def summarylist(myglsalist, fd1=sys.stdout, fd2=sys.stderr):
                fd1.write(")")
                if list_cve:
                        fd1.write(" "+(",".join([r[:13] for r in myglsa.references if r[:4] in ["CAN-", "CVE-"]])))
-               fd1.write("\n")         
+               fd1.write("\n")
        return 0
 
 if mode == "list":
@@ -267,7 +267,7 @@ if mode == "mail":
        import portage.mail, socket
        from io import StringIO
        from email.mime.text import MIMEText
-       
+
        # color doesn't make any sense for mail
        nocolor()
 
@@ -275,7 +275,7 @@ if mode == "mail":
                myrecipient = portage.settings["PORTAGE_ELOG_MAILURI"].split()[0]
        else:
                myrecipient = "root@localhost"
-       
+
        if "PORTAGE_ELOG_MAILFROM" in portage.settings:
                myfrom = portage.settings["PORTAGE_ELOG_MAILFROM"]
        else:
@@ -303,12 +303,12 @@ if mode == "mail":
                myglsa.dump(outstream=myfd)
                myattachments.append(MIMEText(str(myfd.getvalue()), _charset="utf8"))
                myfd.close()
-               
+
        mymessage = portage.mail.create_message(myfrom, myrecipient, mysubject, summary, myattachments)
        portage.mail.send_mail(portage.settings, mymessage)
-               
+
        sys.exit(0)
-       
+
 # something wrong here, all valid paths are covered with sys.exit()
 sys.stderr.write("nothing more to do\n")
 sys.exit(2)
index db023e48a90857e7a5759f1052380fff9bdee050..853489a04218be589e56235291ffacb7d287b06d 100755 (executable)
@@ -397,7 +397,7 @@ install_qa_check() {
 
                # Check for files built without respecting LDFLAGS
                if [[ "${LDFLAGS}" == *,--hash-style=gnu* ]] && \
-                       ! has binchecks ${RESTRICT} ; then 
+                       ! has binchecks ${RESTRICT} ; then
                        f=$(scanelf -qyRF '%k %p' -k .hash "${ED}" | sed -e "s:\.hash ::")
                        if [[ -n ${f} ]] ; then
                                echo "${f}" > "${T}"/scanelf-ignored-LDFLAGS.log
@@ -620,8 +620,8 @@ install_qa_check() {
                done
        done
 
-       # When installing static libraries into /usr/lib and shared libraries into 
-       # /lib, we have to make sure we have a linker script in /usr/lib along side 
+       # When installing static libraries into /usr/lib and shared libraries into
+       # /lib, we have to make sure we have a linker script in /usr/lib along side
        # the static library, or gcc will utilize the static lib when linking :(.
        # http://bugs.gentoo.org/4411
        abort="no"
@@ -1121,10 +1121,10 @@ preinst_selinux_labels() {
                        (
                                eval "$(/usr/sbin/selinuxconfig)" || \
                                        die "Failed to determine SELinux policy paths.";
-       
+
                                addwrite /selinux/context
                                addwrite /sys/fs/selinux/context
-       
+
                                /usr/sbin/setfiles "${file_contexts_path}" -r "${D}" "${D}"
                        ) || die "Failed to set SELinux security labels."
                else
index 91a98153b21d7ec2212e048fa50526424cd27733..7ecdc6d199c91f1424e19d317e1c55e0f8166b23 100755 (executable)
@@ -125,7 +125,7 @@ signal.signal(signal.SIGINT,exithandler)
 class RepomanHelpFormatter(optparse.IndentedHelpFormatter):
        """Repoman needs it's own HelpFormatter for now, because the default ones
        murder the help text."""
-       
+
        def __init__(self, indent_increment=1, max_help_position=24, width=150, short_first=1):
                optparse.HelpFormatter.__init__(self, indent_increment, max_help_position, width, short_first)
 
@@ -135,7 +135,7 @@ class RepomanHelpFormatter(optparse.IndentedHelpFormatter):
 class RepomanOptionParser(optparse.OptionParser):
        """Add the on_tail function, ruby has it, optionParser should too
        """
-       
+
        def __init__(self, *args, **kwargs):
                optparse.OptionParser.__init__(self, *args, **kwargs)
                self.tail = ""
@@ -169,7 +169,7 @@ def ParseArgs(argv, qahelp):
                'help' : 'Show this screen',
                'manifest' : 'Generate a Manifest (fetches files if necessary)',
                'manifest-check' : 'Check Manifests for missing or incorrect digests',
-               'scan' : 'Scan directory tree for QA issues' 
+               'scan' : 'Scan directory tree for QA issues'
        }
 
        mode_keys = list(modes)
@@ -196,7 +196,7 @@ def ParseArgs(argv, qahelp):
 
        parser.add_option('-p', '--pretend', dest='pretend', default=False,
                action='store_true', help='don\'t commit or fix anything; just show what would be done')
-       
+
        parser.add_option('-q', '--quiet', dest="quiet", action="count", default=0,
                help='do not print unnecessary messages')
 
@@ -244,7 +244,7 @@ def ParseArgs(argv, qahelp):
        parser.add_option('--without-mask', dest='without_mask', action='store_true',
                default=False, help='behave as if no package.mask entries exist (not allowed with commit mode)')
 
-       parser.add_option('--mode', type='choice', dest='mode', choices=list(modes), 
+       parser.add_option('--mode', type='choice', dest='mode', choices=list(modes),
                help='specify which mode repoman will run in (default=full)')
 
        parser.on_tail("\n " + green("Modes".ljust(20) + " Description\n"))
@@ -279,7 +279,7 @@ def ParseArgs(argv, qahelp):
 
        if not opts.mode:
                opts.mode = 'full'
-       
+
        if opts.mode == 'ci':
                opts.mode = 'commit'  # backwards compat shortcut
 
@@ -329,7 +329,7 @@ qahelp={
        "KEYWORDS.dropped":"Ebuilds that appear to have dropped KEYWORDS for some arch",
        "KEYWORDS.missing":"Ebuilds that have a missing or empty KEYWORDS variable",
        "KEYWORDS.stable":"Ebuilds that have been added directly with stable KEYWORDS",
-       "KEYWORDS.stupid":"Ebuilds that use KEYWORDS=-* instead of package.mask", 
+       "KEYWORDS.stupid":"Ebuilds that use KEYWORDS=-* instead of package.mask",
        "LICENSE.missing":"Ebuilds that have a missing or empty LICENSE variable",
        "LICENSE.virtual":"Virtuals that have a non-empty LICENSE variable",
        "DESCRIPTION.missing":"Ebuilds that have a missing or empty DESCRIPTION variable",
@@ -1632,7 +1632,7 @@ for x in effective_scanlist:
        if check_changelog and "ChangeLog" not in checkdirlist:
                stats["changelog.missing"]+=1
                fails["changelog.missing"].append(x+"/ChangeLog")
-       
+
        musedict = {}
        #metadata.xml file check
        if "metadata.xml" not in checkdirlist:
@@ -1995,7 +1995,7 @@ for x in effective_scanlist:
 
                badlicsyntax = len([z for z in type_list if z == "LICENSE"])
                badprovsyntax = len([z for z in type_list if z == "PROVIDE"])
-               baddepsyntax = len(type_list) != badlicsyntax + badprovsyntax 
+               baddepsyntax = len(type_list) != badlicsyntax + badprovsyntax
                badlicsyntax = badlicsyntax > 0
                badprovsyntax = badprovsyntax > 0
 
@@ -2025,7 +2025,7 @@ for x in effective_scanlist:
 
                for mypos in range(len(myuse)):
                        stats["IUSE.invalid"]=stats["IUSE.invalid"]+1
-                       fails["IUSE.invalid"].append(x+"/"+y+".ebuild: %s" % myuse[mypos])      
+                       fails["IUSE.invalid"].append(x+"/"+y+".ebuild: %s" % myuse[mypos])
 
                # license checks
                if not badlicsyntax:
@@ -2127,7 +2127,7 @@ for x in effective_scanlist:
                                # A missing profile will create an error further down
                                # during the KEYWORDS verification.
                                continue
-                               
+
                        for prof in profiles[arch]:
 
                                if prof.status not in ("stable", "dev") or \
@@ -2192,7 +2192,7 @@ for x in effective_scanlist:
                                                suffix=suffix+"indev"
 
                                        for mytype in Package._dep_keys:
-                                               
+
                                                mykey = "dependency.bad" + suffix
                                                myvalue = myaux[mytype]
                                                if not myvalue:
@@ -2403,7 +2403,7 @@ else:
                with repoman_popen("hg status --no-status --unknown .") as f:
                        myunadded = f.readlines()
                myunadded = ["./" + elem.rstrip() for elem in myunadded]
-               
+
                # Mercurial doesn't handle manually deleted files as removed from
                # the repository, so the user need to remove them before commit,
                # using "hg remove [FILES]"
@@ -2707,7 +2707,7 @@ else:
                        elif vcs == "svn":
                                if myfile not in expansion:
                                        continue
-                               
+
                                # Subversion keywords are case-insensitive in svn:keywords properties, but case-sensitive in contents of files.
                                enabled_keywords = []
                                for k in expansion[myfile]: