Version bump; fix for bug #45482
authorStuart Herbert <stuart@gentoo.org>
Tue, 30 Mar 2004 20:30:49 +0000 (20:30 +0000)
committerStuart Herbert <stuart@gentoo.org>
Tue, 30 Mar 2004 20:30:49 +0000 (20:30 +0000)
net-www/phpBB/ChangeLog
net-www/phpBB/Manifest
net-www/phpBB/files/digest-phpBB-2.0.8a [new file with mode: 0644]
net-www/phpBB/phpBB-2.0.8a.ebuild [new file with mode: 0644]

index b9453ca5c93f9c5f8081b3b7594553322709f2c2..67b9bf476688326305391e5cc0412a21654d935c 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for net-www/phpBB
 # Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/ChangeLog,v 1.10 2004/03/02 16:18:13 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/ChangeLog,v 1.11 2004/03/30 20:30:48 stuart Exp $
+
+*phpBB-2.0.8a (30 Mar 2004)
+
+  30 Mar 2004; Stuart Herbert <stuart@gentoo.org> phpBB-2.0.8a.ebuild:
+  Version bump; for bug #45482
 
 *phpBB-2.0.6-r2 (02 Mar 2004)
 
index 845e8a0418895da740f942106cd4acc7864282c3..c8cd9bf78c7180eb327edf3dca06a2c3d7f0f2ee 100644 (file)
@@ -1,7 +1,9 @@
 MD5 7c07009af241c73521e5d2cc39467d25 phpBB-2.0.6-r1.ebuild 1331
+MD5 2a8d2fff9d2e745ad047c711c6e11f75 ChangeLog 1540
 MD5 c339473e0ff43da76eb2f2607c441921 metadata.xml 280
-MD5 ed96d073875432ebb4463a7dc762fb03 ChangeLog 1409
 MD5 0329a803da692e6e047fdd0f9b1d21b5 phpBB-2.0.6-r2.ebuild 1261
-MD5 81edef11555fd2672d5ccc894ce8b711 files/digest-phpBB-2.0.6-r2 64
+MD5 6fc277910a0ad79e0af06ea0851866be phpBB-2.0.8a.ebuild 1258
 MD5 2bcc15b387e45c0342ace8fe007ada43 files/digest-phpBB-2.0.6-r1 64
 MD5 baf12ebb39a1b14b5b0bf0fa9320eba8 files/phpBB-2.0.6-security.patch 248
+MD5 81edef11555fd2672d5ccc894ce8b711 files/digest-phpBB-2.0.6-r2 64
+MD5 a5490792af02884bb7bfd22efa001697 files/digest-phpBB-2.0.8a 65
diff --git a/net-www/phpBB/files/digest-phpBB-2.0.8a b/net-www/phpBB/files/digest-phpBB-2.0.8a
new file mode 100644 (file)
index 0000000..76fef3c
--- /dev/null
@@ -0,0 +1 @@
+MD5 44d33a5851800f8f278d3c100fb2fcb3 phpBB-2.0.8a.tar.bz2 457308
diff --git a/net-www/phpBB/phpBB-2.0.8a.ebuild b/net-www/phpBB/phpBB-2.0.8a.ebuild
new file mode 100644 (file)
index 0000000..6d7e2f0
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/phpBB-2.0.8a.ebuild,v 1.1 2004/03/30 20:30:48 stuart Exp $
+
+inherit webapp-apache
+
+DESCRIPTION="phpBB is a high powered, fully scalable, and highly customisable open-source bulletin board package."
+HOMEPAGE="http://www.phpbb.com/"
+SRC_URI="mirror://sourceforge/phpbb/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+RESTRICT="nomirror"
+
+DEPEND=">=sys-devel/patch-2.5.9"
+RDEPEND="virtual/php"
+
+S=${WORKDIR}/${PN}2
+
+pkg_setup() {
+       webapp-detect || NO_WEBSERVER=1
+
+       webapp-pkg_setup "${NO_WEBSERVER}"
+
+       if [ -d ${HTTPD_ROOT}/phpbb ] ; then
+               ewarn "You need to unmerge your old phpBB version first."
+               ewarn "phpBB will be installed into ${HTTPD_ROOT}/phpbb"
+               ewarn "directly instead of a version-dependant directory."
+               die "need to unmerge old version first"
+       fi
+
+       einfo "Installing for ${WEBAPP_SERVER}"
+}
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+}
+
+src_install() {
+       webapp-mkdirs
+
+       dodir "${HTTPD_ROOT}/phpbb"
+       cp -a * "${D}/${HTTPD_ROOT}/phpbb"
+       dodoc ${S}/docs/*
+
+       cd "${D}/${HTTPD_ROOT}"
+       chown -R "${HTTPD_USER}:${HTTPD_GROUP}" "${D}/${HTTPD_ROOT}/phpbb"
+}