dev-python/django-prometheus: export django metrics to prometheus
authorWilliam Hubbs <william.hubbs@sony.com>
Mon, 15 Jul 2019 22:15:58 +0000 (17:15 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Mon, 15 Jul 2019 22:17:30 +0000 (17:17 -0500)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: William Hubbs <williamh@gentoo.org>
dev-python/django-prometheus/Manifest [new file with mode: 0644]
dev-python/django-prometheus/django-prometheus-1.0.15.ebuild [new file with mode: 0644]
dev-python/django-prometheus/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/django-prometheus/Manifest b/dev-python/django-prometheus/Manifest
new file mode 100644 (file)
index 0000000..8fe0bdc
--- /dev/null
@@ -0,0 +1 @@
+DIST django-prometheus-1.0.15.tar.gz 13708 BLAKE2B 64d72224da9cb481108ad17ed1409d97108353a39894f824428743f3ee894292352de4d4beebf1984294e34cea7b6d0144c5066d0fe5cca7d9c682f9410355d3 SHA512 48794f6d07ebdd3487060e62e808a66a97630045433dd91a27f1095f79a72197124c44c5d178c89785b8d048e8e828f84804c789cb5c2f0a053cf18864cde6eb
diff --git a/dev-python/django-prometheus/django-prometheus-1.0.15.ebuild b/dev-python/django-prometheus/django-prometheus-1.0.15.ebuild
new file mode 100644 (file)
index 0000000..fe4f692
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="Library to export django metrics for prometheus"
+HOMEPAGE="https://github.com/korfuri/django-prometheus"
+SRC_URI="mirror://pypi/${PN:0:1}"/${PN}/${P}.tar.gz
+
+LICENSE="Apache-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-python/prometheus_client-0.0.21[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/django-prometheus/metadata.xml b/dev-python/django-prometheus/metadata.xml
new file mode 100644 (file)
index 0000000..c36c371
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>williamh@gentoo.org</email>
+               <name>William Hubbs</name>
+       </maintainer>
+</pkgmetadata>