app-backup/mkstage4: version bump 0.3
authorHorea Christian <chr@chymera.eu>
Mon, 6 Apr 2020 03:33:02 +0000 (23:33 -0400)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 10 Apr 2020 07:10:30 +0000 (10:10 +0300)
and updated metadata

Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Horea Christian <chr@chymera.eu>
Closes: https://github.com/gentoo/gentoo/pull/15244
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-backup/mkstage4/Manifest
app-backup/mkstage4/metadata.xml
app-backup/mkstage4/mkstage4-0.3.ebuild [new file with mode: 0644]

index 816eb358db5d0b3ead762f59ec9bba23ec4478cc..5193f2f5639499dc50b41c73e8388494b55f325e 100644 (file)
@@ -1,2 +1,3 @@
 DIST mkstage4-0.1.tar.gz 15220 BLAKE2B 43f091615d4fbb19495c2103729556ec307501f93c60bd0df676f710868d932dc7bb7e0a1c2f6613d0cc2edc266f9b9f7b74e534e84a7d41a4bf4f66c09f98e4 SHA512 e42d23ffe214c9fef8dde94f8b8faa32490e9e553f182f042a2c4d713a72031c9560e291b6231a0ced812e43f80a58cb3fa5bfdc4ad7e132d7ea7c74525d64c5
 DIST mkstage4-0.2.tar.gz 15998 BLAKE2B 47ce4335ea5dd9cc0defb2897912ce3169e1ef23d03435ed7500a33f26e5646b1b97aebcac286a93e631f11c491cb076831d62c7b565493458c0882e6f359b94 SHA512 31b77782e6b79db1cb1db7baf30a2bd96e828861a9085b257d554d0991ea16299c3cc9a6e3fa2af5738aeb3ffbd040f6627af3510ccb8fd744b59658acc2dd55
+DIST mkstage4-0.3.tar.gz 18648 BLAKE2B 3a881bc1ec14f5c9795d49306966b586c30a8b415542fb500b5a2af7735008832ebc64f0a166ea4e2fdb48a555bd789b352784f1b05118116ae3f634937beed6 SHA512 6971bf4b43a2fdef0b54802b010c99e95caf896c8e109c54f5a6beb4db1714ea5639e0859ba3f958eed92b9fc6a3bb613bb82de440729e71e53543d60549d2db
index 18dfa0f4ba424daf9f9af55f06ebe72a4626038a..48c9ac6ebccd54f1c7c9544ce60a0dc1c0424d80 100644 (file)
                <name>Proxy Maintainers</name>
        </maintainer>
        <longdescription lang="en">
-               This is a bash script to create stage 4 tarballs either for the 
-               running system, or a system at a specified mount point. It is 
-               highly parameterized allowing the exclusion of sensitive user
-               data.
+               This is a bash script which can create stage 4 tarballs either
+               for the running system, or a system at a specified mount point.
+               It is highly parameterized allowing among other things the
+               exclusion of sensitive user data.
        </longdescription>
        <upstream>
                <remote-id type="github">TheChymera/mkstage4</remote-id>
diff --git a/app-backup/mkstage4/mkstage4-0.3.ebuild b/app-backup/mkstage4/mkstage4-0.3.ebuild
new file mode 100644 (file)
index 0000000..cd2b213
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Bash Utility for Creating Stage 4 Tarballs"
+HOMEPAGE="https://github.com/TheChymera/mkstage4"
+SRC_URI="https://github.com/TheChymera/mkstage4/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-util/bats )"
+RDEPEND="
+       app-shells/bash
+       app-arch/tar
+"
+
+src_install() {
+       newbin mkstage4.sh mkstage4
+}
+
+src_test() {
+       bats tests/* || die
+}