dev-python/flask-api: verbump to 2.0
authorDavid Roman <davidroman96@gmail.com>
Wed, 6 May 2020 13:30:17 +0000 (15:30 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 17 May 2020 16:41:51 +0000 (19:41 +0300)
Closes: https://bugs.gentoo.org/717522
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: David Roman <davidroman96@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/15665
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/flask-api/Manifest
dev-python/flask-api/flask-api-2.0.ebuild [new file with mode: 0644]

index 8500aa3b068c68c95a63222891a7a181333a01ed..7b941f13e487416ff15370b09e29de8bb83bf6e8 100644 (file)
@@ -1 +1,2 @@
 DIST flask-api-1.1.tar.gz 235042 BLAKE2B b3c7e476c8ef1fa21f7e60aa1fb87ef5b40708ea96332ca0290d9355552bc5c195914da769b39ace1d34864c32989cf7f9856d070b1e6b690a6c1f60b495cabc SHA512 52bb983bf9a0f906f37b645ff907eaa6ee3bc557b51f8935817963f3d66d99689eeba6a3e17711974663ad5ede267f9c85eb1d11f27597fe63806dc9f9e7ea22
+DIST flask-api-2.0.tar.gz 235593 BLAKE2B fadd746d91cc2c797a2e40ee6b11532eb0184a1289a692f8de844501a6656eaa1e87d10811119f267344185b22ed5c12bca43198d64d50ca8055ce95d0f62f19 SHA512 631e69e5a786598e6b5ef7e02c5c4f293eadd84d86fdf0155771d04fb6e87be5686756db90ab265cc097ae3d623c31dcebf5096a62c660d6f7d6fb1c3f3d4e3f
diff --git a/dev-python/flask-api/flask-api-2.0.ebuild b/dev-python/flask-api/flask-api-2.0.ebuild
new file mode 100644 (file)
index 0000000..e2fe9c1
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Browsable web APIs for Flask"
+HOMEPAGE="https://github.com/flask-api/flask-api"
+# pypi mirror don't have docs folder
+SRC_URI="https://github.com/flask-api/flask-api/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+       dev-python/markdown[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+       distutils-r1_python_install_all
+       dodoc docs/about/* docs/api-guide/* docs/index.md
+}