app-arch/tar: Bump to version 1.31
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 3 Jan 2019 00:19:37 +0000 (01:19 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 3 Jan 2019 00:19:37 +0000 (01:19 +0100)
Package-Manager: Portage-2.3.53, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
app-arch/tar/Manifest
app-arch/tar/tar-1.31.ebuild [new file with mode: 0644]

index 4d3b42f1260cc3c426873b6262b62083fc8d46d3..686dbf3e93baf520079ddf35d754dd301cfed113 100644 (file)
@@ -1 +1,2 @@
 DIST tar-1.30.tar.bz2 2858639 BLAKE2B 82a8b1fbf1eb5c0347b2f8cf35854498e2955eb85eaf041ec44a38bbd9bc82cc7184d5cb858f9905f503c9178ec6d0ed50be2dc27be9933b29e0a18b8e6c0b8f SHA512 07a1157430898fee1a2c6fd3853d59d4ae13998db685669c8c702f73d2466eeb9892f84a5f0495bfe088c8190a643a99ac9f2cb16b85c9fe3ae0d83cc0f338e8
+DIST tar-1.31.tar.bz2 2946047 BLAKE2B c85c17740e4cd3e8c93d10d93b070cd80629b7f052d020c0513cdddd377f3f90e229a6fa10dfbb43e1006f8202c674f2df854b864c0947f49339a52964d65c1c SHA512 0f4d00e08d56a8f8c32aac0afa2845397efb8ad72eaa6af47334cef9612adb1a4b91406bdc2c3a2cf1b9cc8b92c12735a331e0d137b24f66703f6af6219464f6
diff --git a/app-arch/tar/tar-1.31.ebuild b/app-arch/tar/tar-1.31.ebuild
new file mode 100644 (file)
index 0000000..9008c8d
--- /dev/null
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="Use this to make tarballs :)"
+HOMEPAGE="https://www.gnu.org/software/tar/"
+SRC_URI="mirror://gnu/tar/${P}.tar.bz2
+       mirror://gnu-alpha/tar/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="acl elibc_glibc minimal nls selinux static userland_GNU xattr"
+
+RDEPEND="acl? ( virtual/acl )
+       selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+       nls? ( >=sys-devel/gettext-0.10.35 )
+       xattr? ( elibc_glibc? ( sys-apps/attr ) )"
+
+src_prepare() {
+       default
+
+       if ! use userland_GNU ; then
+               sed -i \
+                       -e 's:/backup\.sh:/gbackup.sh:' \
+                       scripts/{backup,dump-remind,restore}.in \
+                       || die "sed non-GNU"
+       fi
+}
+
+src_configure() {
+       use static && append-ldflags -static
+       local myeconfargs=(
+               --bindir="${EPREFIX}"/bin
+               --enable-backup-scripts
+               --libexecdir="${EPREFIX}"/usr/sbin
+               $(usex userland_GNU "" "--program-prefix=g")
+               $(use_with acl posix-acls)
+               $(use_enable nls)
+               $(use_with selinux)
+               $(use_with xattr xattrs)
+       )
+       FORCE_UNSAFE_CONFIGURE=1 econf "${myeconfargs[@]}"
+}
+
+src_install() {
+       default
+
+       local p=$(usex userland_GNU "" "g")
+       if [[ -z ${p} ]] ; then
+               # a nasty yet required piece of baggage
+               exeinto /etc
+               doexe "${FILESDIR}"/rmt
+       fi
+
+       # autoconf looks for gtar before tar (in configure scripts), hence
+       # in Prefix it is important that it is there, otherwise, a gtar from
+       # the host system (FreeBSD, Solaris, Darwin) will be found instead
+       # of the Prefix provided (GNU) tar
+       if use prefix ; then
+               dosym tar /bin/gtar
+       fi
+
+       mv "${ED%/}"/usr/sbin/${p}backup{,-tar} || die
+       mv "${ED%/}"/usr/sbin/${p}restore{,-tar} || die
+
+       if use minimal ; then
+               find "${ED}"/etc "${ED}"/*bin/ "${ED}"/usr/*bin/ \
+                       -type f -a '!' '(' -name tar -o -name ${p}tar ')' \
+                       -delete || die
+       fi
+}