dev-libs/libcroco: bump to 0.6.12
authorMart Raudsepp <leio@gentoo.org>
Sat, 8 Apr 2017 23:13:26 +0000 (02:13 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sat, 8 Apr 2017 23:13:27 +0000 (02:13 +0300)
Really only has documentation and information/debug message english spelling fixes

dev-libs/libcroco/Manifest
dev-libs/libcroco/libcroco-0.6.12.ebuild [new file with mode: 0644]

index 472c62d1d943781b60ad4330a3e6b08c84653ad9..baf105ae9c90a9899a4c090f124261aa2fae9649 100644 (file)
@@ -1 +1,2 @@
 DIST libcroco-0.6.11.tar.xz 477312 SHA256 132b528a948586b0dfa05d7e9e059901bca5a3be675b6071a90a90b81ae5a056 SHA512 441b9c6d9b6acd4ff908100573c6f24bcf46a20ec94360bdcf4765e37a7d45dc59e6a0889917f3486503b274d05cd79a63178e74d029209c16b8e3351a1160da WHIRLPOOL e4874167bd8d1336ed2ad6180d7780962da0f84ac09b24652105baea34a46769881f8112900e606312bf1d7c01045d8cfc187c8c327bbd834bba70a982edbcb9
+DIST libcroco-0.6.12.tar.xz 482028 SHA256 ddc4b5546c9fb4280a5017e2707fbd4839034ed1aba5b7d4372212f34f84f860 SHA512 af9a171d5ccded255b57f170576e67155f12fa0f61ab3e379e907975f77afc37e82e22772c6019b2897cffc15b2425faf3ccfda92b1a45b23eda2519debabeb6 WHIRLPOOL b3626257b56b9e104307cd3da01366a5eb929d0afc6669a80f4a94748c434afdc8c3828e008ab786ab28ca72d799a79804e9a296d9428504829521516366e039
diff --git a/dev-libs/libcroco/libcroco-0.6.12.ebuild b/dev-libs/libcroco/libcroco-0.6.12.ebuild
new file mode 100644 (file)
index 0000000..39ed01b
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="Generic Cascading Style Sheet (CSS) parsing and manipulation toolkit"
+HOMEPAGE="https://git.gnome.org/browse/libcroco/"
+
+LICENSE="LGPL-2"
+SLOT="0.6"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+       >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+       >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       dev-util/gtk-doc-am
+       >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
+
+src_prepare() {
+       if ! use test; then
+               # don't waste time building tests
+               sed 's/^\(SUBDIRS .*\=.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+                       || die "sed failed"
+       fi
+
+       gnome2_src_prepare
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE=${S} \
+       gnome2_src_configure \
+               --disable-static \
+               $([[ ${CHOST} == *-darwin* ]] && echo --disable-Bsymbolic)
+
+       if multilib_is_native_abi; then
+               ln -s "${S}"/docs/reference/html docs/reference/html || die
+       fi
+}
+
+multilib_src_install() {
+       gnome2_src_install
+}
+
+multilib_src_install_all() {
+       DOCS="AUTHORS ChangeLog HACKING NEWS README TODO"
+       einstalldocs
+}