x11-misc/qtfm: EAPI bump 4 -> 6
authorHarri Nieminen <moikkis@gmail.com>
Wed, 1 Mar 2017 17:15:58 +0000 (19:15 +0200)
committerDavid Seifert <soap@gentoo.org>
Wed, 1 Mar 2017 20:45:03 +0000 (21:45 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Closes: https://github.com/gentoo/gentoo/pull/4091

x11-misc/qtfm/qtfm-5.5-r1.ebuild [new file with mode: 0644]

diff --git a/x11-misc/qtfm/qtfm-5.5-r1.ebuild b/x11-misc/qtfm/qtfm-5.5-r1.ebuild
new file mode 100644 (file)
index 0000000..eaff4fb
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit fdo-mime qmake-utils
+
+DESCRIPTION="A small, lightweight file manager for desktops based on pure Qt"
+HOMEPAGE="http://www.qtfm.org/"
+SRC_URI="http://www.qtfm.org/${P}.tar.gz?attredirects=0 -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# file is for LIBS += -lmagic
+RDEPEND="sys-apps/file
+       dev-qt/qtgui:4"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+       default
+       sed -i \
+               -e "/^docs.path/s:qtfm:${PF}:" \
+               -e '/^docs.files/s: COPYING::' \
+               ${PN}.desktop || die
+       sed -i \
+               -e '/MimeType=/s|$|;|' \
+               -e '/Categories=/s|$|;System;FileTools;|' \
+               ${PN}.desktop || die
+}
+
+src_configure() {
+       eqmake4
+}
+
+src_install() {
+       emake INSTALL_ROOT="${D}" install
+       einstalldocs
+}
+
+pkg_postinst() {
+       fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+       fdo-mime_desktop_database_update
+}