app-text/xournalpp: New package
authorAndreas K. Huettel <dilfridge@gentoo.org>
Sat, 22 Feb 2020 20:12:49 +0000 (21:12 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 22 Feb 2020 20:12:49 +0000 (21:12 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Closes: https://github.com/gentoo/gentoo/pull/14744
Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>
Signed-off-by: David Seifert <soap@gentoo.org>
app-text/xournalpp/Manifest [new file with mode: 0644]
app-text/xournalpp/files/xournalpp-1.0.17-translations.patch [new file with mode: 0644]
app-text/xournalpp/metadata.xml [new file with mode: 0644]
app-text/xournalpp/xournalpp-1.0.17.ebuild [new file with mode: 0644]
app-text/xournalpp/xournalpp-9999.ebuild [new file with mode: 0644]

diff --git a/app-text/xournalpp/Manifest b/app-text/xournalpp/Manifest
new file mode 100644 (file)
index 0000000..24b899e
--- /dev/null
@@ -0,0 +1 @@
+DIST xournalpp-1.0.17.tgz 14885382 BLAKE2B 501feb4480eee5aa38cc148f561d6c730505e43fd5d8017936f4b1d15f1b83ae936eb0a2e81b9889c668f9ed0a9c46b9053c984d45815c88829b023b7dbbd209 SHA512 cc3568ce22fd42f0e8458f1428c102d2fc18a9650d8c5968cadd6693fc19374780beb3c7f6206f2f494439296a883b2a5160da37e3a0e10d6fe3654084967ab9
diff --git a/app-text/xournalpp/files/xournalpp-1.0.17-translations.patch b/app-text/xournalpp/files/xournalpp-1.0.17-translations.patch
new file mode 100644 (file)
index 0000000..95283b0
--- /dev/null
@@ -0,0 +1,24 @@
+From 12387b01a1c7e529580c6f27e92dad3e8b4f9858 Mon Sep 17 00:00:00 2001
+From: Bryan Tan <techniux@gmail.com>
+Date: Fri, 7 Feb 2020 19:47:18 -0800
+Subject: [PATCH] Fix translation target
+
+- Do not modify po files in place
+- Always build translations
+---
+ po/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
+index f957a199d..73ce0f04f 100644
+--- a/po/CMakeLists.txt
++++ b/po/CMakeLists.txt
+@@ -20,7 +20,7 @@ if (XGETTEXT_FOUND)
+       "${PROJECT_SOURCE_DIR}/ui/*.glade"
+   )
+-  gettext_create_translations ("${potfile}")
++  gettext_create_translations ("${potfile}" ALL NOUPDATE)
+ else (XGETTEXT_FOUND)
+   message (ERROR "Gettext not found!")
diff --git a/app-text/xournalpp/metadata.xml b/app-text/xournalpp/metadata.xml
new file mode 100644 (file)
index 0000000..b1dfcef
--- /dev/null
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>dilfridge@gentoo.org</email>
+       </maintainer>
+</pkgmetadata>
diff --git a/app-text/xournalpp/xournalpp-1.0.17.ebuild b/app-text/xournalpp/xournalpp-1.0.17.ebuild
new file mode 100644 (file)
index 0000000..4dac69f
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils xdg
+
+if [[ ${PV} == *9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/xournalpp/xournalpp.git"
+       unset SRC_URI
+else
+       KEYWORDS="~amd64"
+       SRC_URI="https://github.com/xournalpp/xournalpp/archive/${PV}.tar.gz -> ${P}.tgz"
+fi
+
+DESCRIPTION="Handwriting notetaking software with PDF annotation support"
+HOMEPAGE="https://github.com/xournalpp/xournalpp"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+COMMONDEPEND="
+       app-text/poppler
+       dev-libs/glib
+       dev-libs/libxml2
+       dev-libs/libzip:=
+       media-libs/portaudio
+       media-libs/libsndfile
+       sys-libs/zlib:=
+       x11-libs/gtk+:3
+"
+RDEPEND="${COMMONDEPEND}
+"
+DEPEND="${COMMONDEPEND}
+"
+BDEPEND="
+       virtual/pkgconfig
+       sys-apps/lsb-release
+"
+
+PATCHES=(
+       "${FILESDIR}/${P}-translations.patch"
+)
+
+src_prepare() {
+       cmake-utils_src_prepare
+}
diff --git a/app-text/xournalpp/xournalpp-9999.ebuild b/app-text/xournalpp/xournalpp-9999.ebuild
new file mode 100644 (file)
index 0000000..6cb1258
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils xdg
+
+if [[ ${PV} == *9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/xournalpp/xournalpp.git"
+       unset SRC_URI
+else
+       KEYWORDS="~amd64"
+       SRC_URI="https://github.com/xournalpp/xournalpp/archive/${PV}.tar.gz -> ${P}.tgz"
+fi
+
+DESCRIPTION="Handwriting notetaking software with PDF annotation support"
+HOMEPAGE="https://github.com/xournalpp/xournalpp"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+COMMONDEPEND="
+       app-text/poppler
+       dev-libs/glib
+       dev-libs/libxml2
+       dev-libs/libzip:=
+       media-libs/portaudio
+       media-libs/libsndfile
+       sys-libs/zlib:=
+       x11-libs/gtk+:3
+"
+RDEPEND="${COMMONDEPEND}
+"
+DEPEND="${COMMONDEPEND}
+"
+BDEPEND="
+       virtual/pkgconfig
+       sys-apps/lsb-release
+"
+
+src_prepare() {
+       cmake-utils_src_prepare
+}