dev-lang/rust: handle libdir workaround on arm as well
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Thu, 6 Jun 2019 05:53:37 +0000 (22:53 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Thu, 6 Jun 2019 05:56:39 +0000 (22:56 -0700)
Bug: https://bugs.gentoo.org/672816
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-lang/rust/rust-1.34.2.ebuild

index c0d1a001cbc336b9d04ecce1a3f9d61c8ffe98ec..8973490b5aa22141b083fe889fe9475e6c5f0658 100644 (file)
@@ -267,12 +267,14 @@ src_install() {
        done
 
        # temp fix for https://bugs.gentoo.org/672816
-       if use x86; then
+       # FIXME: this should handle libdir=lib, not exact arches
+       if { use x86 || use arm; }; then
                local rust_target wrongdir rightdir
                rust_target=$(rust_abi $(get_abi_CHOST ${v##*.}))
                wrongdir="${ED}/usr/$(get_libdir)/${P}/${P}/rustlib/${rust_target}/codegen-backends"
                rightdir="${ED}/usr/$(get_libdir)/${P}/rustlib/${rust_target}/codegen-backends"
                if [[ -e ${wrongdir}/librustc_codegen_llvm-llvm.so ]]; then
+                       einfo "fixing bug #672816"
                        mv "${wrongdir}" "${rightdir}" || die
                        rm -r "${ED}/usr/$(get_libdir)/${P}/${P}" || die
                fi