dev-python/nose_warnings_filters: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:26:13 +0000 (13:26 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:26:13 +0000 (13:26 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/nose_warnings_filters/nose_warnings_filters-0.1.5-r2.ebuild [deleted file]

diff --git a/dev-python/nose_warnings_filters/nose_warnings_filters-0.1.5-r2.ebuild b/dev-python/nose_warnings_filters/nose_warnings_filters-0.1.5-r2.ebuild
deleted file mode 100644 (file)
index 1a35276..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A python module to inject warning filters during nosetest"
-HOMEPAGE="https://github.com/Carreau/nose_warnings_filters"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( ${RDEPEND} )"
-
-python_test() {
-       # nose_warnings_filters doesn't have a proper
-       # testing suite, hence we run the only testing
-       # script available
-       distutils_install_for_testing
-       cd "${TEST_DIR}"/lib || die
-       "${EPYTHON}" "${S}"/${PN}/testing/test_config.py || die "Failed running test script"
-}