app-misc/cdspeed: EAPI7, improve ebuild
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Wed, 1 Aug 2018 16:01:28 +0000 (18:01 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 15 Aug 2018 19:53:29 +0000 (21:53 +0200)
Closes: https://github.com/gentoo/gentoo/pull/9411

app-misc/cdspeed/cdspeed-0.4-r2.ebuild [new file with mode: 0644]

diff --git a/app-misc/cdspeed/cdspeed-0.4-r2.ebuild b/app-misc/cdspeed/cdspeed-0.4-r2.ebuild
new file mode 100644 (file)
index 0000000..6c933ac
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Change the speed of your CD drive"
+HOMEPAGE="http://linuxfocus.org/~guido/"
+SRC_URI="http://linuxfocus.org/~guido/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~x86"
+
+src_prepare() {
+       default
+       sed -i Makefile \
+               -e 's| -o | $(LDFLAGS)&|g' \
+               || die "sed Makefile failed"
+}
+
+src_compile() {
+       emake CFLAGS="${CFLAGS} -Wall -Wno-unused" CC=$(tc-getCC)
+}
+
+src_install() {
+       emake PREFIX="${D}/usr" install
+       dodoc README
+}