Fix KDE bugs #94253, #112449, #136429, #137269 and #141305.
authorCarsten Lohrke <carlo@gentoo.org>
Wed, 11 Apr 2007 20:45:18 +0000 (20:45 +0000)
committerCarsten Lohrke <carlo@gentoo.org>
Wed, 11 Apr 2007 20:45:18 +0000 (20:45 +0000)
Package-Manager: portage-2.1.2.3

kde-base/kaddressbook/ChangeLog
kde-base/kaddressbook/files/digest-kaddressbook-3.5.6-r1 [new file with mode: 0644]
kde-base/kaddressbook/kaddressbook-3.5.6-r1.ebuild [new file with mode: 0644]

index 06d2e2143475723f1b5711244e08070ef514ee44..58c0ff8aaa4d18f30f767114b8da2f04e38ae7c1 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for kde-base/kaddressbook
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/ChangeLog,v 1.71 2007/02/05 12:14:46 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/ChangeLog,v 1.72 2007/04/11 20:45:18 carlo Exp $
+
+*kaddressbook-3.5.6-r1 (11 Apr 2007)
+
+  11 Apr 2007; Carsten Lohrke <carlo@gentoo.org>
+  +kaddressbook-3.5.6-r1.ebuild:
+  Fix KDE bugs #94253, #112449, #136429, #137269 and #141305.
 
   05 Feb 2007; Diego Pettenò <flameeyes@gentoo.org>
   -files/configure-fix-kdepim-gnokii-3.4.patch,
diff --git a/kde-base/kaddressbook/files/digest-kaddressbook-3.5.6-r1 b/kde-base/kaddressbook/files/digest-kaddressbook-3.5.6-r1
new file mode 100644 (file)
index 0000000..e27a001
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 48f1592b07f784df47280baa0c8356b0 kdepim-3.5-patchset-03.tar.bz2 121475
+RMD160 e8aa4e812a3be3d4e13429d487e1e4d466e058b1 kdepim-3.5-patchset-03.tar.bz2 121475
+SHA256 30d4e8d7ac4e11f1a8209bbcb5b39beb044998d4b0d3fa810743a017b38b904b kdepim-3.5-patchset-03.tar.bz2 121475
+MD5 e37e6173fe9fd7f242c9502a4ae1d7de kdepim-3.5.6.tar.bz2 13643798
+RMD160 85f64349d8eedb531895a3591f6fee07c68bf1eb kdepim-3.5.6.tar.bz2 13643798
+SHA256 0b3a04f72fa640d804df1c4cf2c66ac3ccc5033c98e90a7ae9c62611ea8e3a55 kdepim-3.5.6.tar.bz2 13643798
diff --git a/kde-base/kaddressbook/kaddressbook-3.5.6-r1.ebuild b/kde-base/kaddressbook/kaddressbook-3.5.6-r1.ebuild
new file mode 100644 (file)
index 0000000..2cd46af
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/kaddressbook-3.5.6-r1.ebuild,v 1.1 2007/04/11 20:45:18 carlo Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+       mirror://gentoo/kdepim-3.5-patchset-03.tar.bz2"
+
+DESCRIPTION="The KDE Address Book"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gnokii"
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkdepim)
+$(deprange $PV $MAXKDEVER kde-base/libkcal)
+$(deprange $PV $MAXKDEVER kde-base/certmanager)
+$(deprange 3.5.4 $MAXKDEVER kde-base/libkdenetwork)
+$(deprange $PV $MAXKDEVER kde-base/kontact)
+gnokii? ( app-mobilephone/gnokii )"
+
+RDEPEND="${DEPEND}"
+
+KMCOPYLIB="
+       libkdepim libkdepim
+       libkcal libkcal
+       libkleopatra certmanager/lib/
+       libqgpgme libkdenetwork/qgpgme/
+       libkpinterfaces kontact/interfaces/"
+KMEXTRACTONLY="
+       libkdepim/
+       libkdenetwork/
+       libkcal/
+       certmanager/
+       kontact/interfaces/
+       akregator
+       kmail/kmailIface.h"
+KMCOMPILEONLY="
+       libkcal/libical/src/libical/
+       libkcal/libical/src/libicalss/
+       akregator/src/librss"
+       # We add them here because they are standard plugins and programs related to kaddressbook but not a dep of any other kdepim program, so they will be lost if noone install them
+KMEXTRA="
+       kabc/
+       kfile-plugins/vcf
+       kontact/plugins/kaddressbook"
+
+src_compile() {
+       myconf="$myconf $(use_with gnokii)"
+       export DO_NOT_COMPILE="libical" && kde-meta_src_compile myconf configure
+       # generate "ical.h"
+       cd ${S}/libkcal/libical/src/libical && make ical.h
+       # generate "icalss.h"
+       cd ${S}/libkcal/libical/src/libicalss && make icalss.h
+
+       kde-meta_src_compile "make"
+}