net-misc/dropbear: security cleanup (bug #713102)
authorThomas Deutschmann <whissi@gentoo.org>
Wed, 1 Apr 2020 19:18:53 +0000 (21:18 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Wed, 1 Apr 2020 19:19:06 +0000 (21:19 +0200)
Bug: https://bugs.gentoo.org/713102
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
net-misc/dropbear/Manifest
net-misc/dropbear/dropbear-2017.75.ebuild [deleted file]
net-misc/dropbear/dropbear-2018.76.ebuild [deleted file]

index bd290b6381ecd053fda934dde32cac135d2f1be8..b40fc58dbf5bf26d861c68d194ac1ae8195fbe66 100644 (file)
@@ -1,3 +1 @@
-DIST dropbear-2017.75.tar.bz2 1623392 BLAKE2B c024037d3ebcb3f16aed2a5f24e07c06699a510b327a0ea528db7160ad2a8e554af2a233a266f869e0e30c78f3b0b7792a817d9c07f058f605dbf2dc749a4fda SHA512 9c2f2a5e718339f83abc0ad7719bda12bfc75e5bcb87a7c0eec0afefc743e5c0a1575d290d5fde152ff2100b0f0e6fd5ef4431f7bbcb5ca9a332d93c20f5a8f4
-DIST dropbear-2018.76.tar.bz2 2688697 BLAKE2B 1c22d38487e94427b2678d070f8d370eb09bb2d69253fd6f76d8d80fd637ff86a44b00ab42e1f6d84042c72cbcbd4bb6cbb415f961502e0437c7c8c1b812f059 SHA512 82323279f7e78c366ba1ea07ff242259132b2576122429f54326518dd6092aba8ae5de4a0b8a3cef7efc3507015741abe2ac23376c03b40b247527da7a88120e
 DIST dropbear-2019.78.tar.bz2 2708659 BLAKE2B 212b173cfea8655b43a8d93422dd4d3e0d669a67681cb17d6494b6083e6e4c58d21d52850c0cdf414617ee3dcaa071e376d0b5b156b6856cee2e4fe111550f7d SHA512 f667ba8dae17ea89c118642b566f2c134c71bfd0b8bacea5cf7ec87d75ac79bd7cd1864a8788367a89d30ee35427d389ef6416375adff6e83caae30ff3e0549f
diff --git a/net-misc/dropbear/dropbear-2017.75.ebuild b/net-misc/dropbear/dropbear-2017.75.ebuild
deleted file mode 100644 (file)
index ea75386..0000000
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils savedconfig pam user
-
-DESCRIPTION="small SSH 2 client/server designed for small memory environments"
-HOMEPAGE="https://matt.ucc.asn.au/dropbear/dropbear.html"
-SRC_URI="https://matt.ucc.asn.au/dropbear/releases/${P}.tar.bz2
-       https://matt.ucc.asn.au/dropbear/testing/${P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="bsdpty minimal multicall pam +shadow static +syslog zlib"
-
-LIB_DEPEND="zlib? ( sys-libs/zlib[static-libs(+)] )
-       dev-libs/libtommath[static-libs(+)]"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
-       pam? ( sys-libs/pam )"
-DEPEND="${RDEPEND}
-       static? ( ${LIB_DEPEND} )"
-RDEPEND+=" pam? ( >=sys-auth/pambase-20080219.1 )"
-
-REQUIRED_USE="pam? ( !static )"
-
-set_options() {
-       progs=(
-               dropbear dbclient dropbearkey
-               $(usex minimal "" "dropbearconvert scp")
-       )
-       makeopts=(
-               MULTI=$(usex multicall 1 0)
-               STATIC=$(usex static 1 0)
-       )
-}
-
-src_prepare() {
-       epatch "${FILESDIR}"/${PN}-0.46-dbscp.patch
-       sed -i \
-               -e '/SFTPSERVER_PATH/s:".*":"/usr/lib/misc/sftp-server":' \
-               options.h || die
-       sed -i \
-               -e '/pam_start/s:sshd:dropbear:' \
-               svr-authpam.c || die
-       restore_config options.h
-}
-
-src_configure() {
-       # XXX: Need to add libtomcrypt to the tree and re-enable this.
-       #       --disable-bundled-libtom
-       econf \
-               $(use_enable zlib) \
-               $(use_enable pam) \
-               $(use_enable !bsdpty openpty) \
-               $(use_enable shadow) \
-               $(use_enable syslog)
-}
-
-src_compile() {
-       set_options
-       emake "${makeopts[@]}" PROGRAMS="${progs[*]}"
-}
-
-src_install() {
-       set_options
-       emake "${makeopts[@]}" PROGRAMS="${progs[*]}" DESTDIR="${D}" install
-       doman *.8
-       newinitd "${FILESDIR}"/dropbear.init.d dropbear
-       newconfd "${FILESDIR}"/dropbear.conf.d dropbear
-       dodoc CHANGES README TODO SMALL MULTI
-
-       # The multi install target does not install the links right.
-       if use multicall ; then
-               cd "${ED}"/usr/bin
-               local x
-               for x in "${progs[@]}" ; do
-                       ln -sf dropbearmulti ${x} || die "ln -s dropbearmulti to ${x} failed"
-               done
-               rm -f dropbear
-               dodir /usr/sbin
-               dosym ../bin/dropbearmulti /usr/sbin/dropbear
-               cd "${S}"
-       fi
-       save_config options.h
-
-       if ! use minimal ; then
-               mv "${ED}"/usr/bin/{,db}scp || die
-       fi
-
-       pamd_mimic system-remote-login dropbear auth account password session
-}
-
-pkg_preinst() {
-       enewgroup sshd 22
-       enewuser sshd 22 -1 /var/empty sshd
-}
diff --git a/net-misc/dropbear/dropbear-2018.76.ebuild b/net-misc/dropbear/dropbear-2018.76.ebuild
deleted file mode 100644 (file)
index 0eaa06d..0000000
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils savedconfig pam user
-
-DESCRIPTION="small SSH 2 client/server designed for small memory environments"
-HOMEPAGE="https://matt.ucc.asn.au/dropbear/dropbear.html"
-SRC_URI="https://matt.ucc.asn.au/dropbear/releases/${P}.tar.bz2
-       https://matt.ucc.asn.au/dropbear/testing/${P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="bsdpty minimal multicall pam +shadow static +syslog zlib"
-
-LIB_DEPEND="zlib? ( sys-libs/zlib[static-libs(+)] )
-       dev-libs/libtommath[static-libs(+)]"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
-       pam? ( sys-libs/pam )"
-DEPEND="${RDEPEND}
-       static? ( ${LIB_DEPEND} )"
-RDEPEND+=" pam? ( >=sys-auth/pambase-20080219.1 )"
-
-REQUIRED_USE="pam? ( !static )"
-
-set_options() {
-       progs=(
-               dropbear dbclient dropbearkey
-               $(usex minimal "" "dropbearconvert scp")
-       )
-       makeopts=(
-               MULTI=$(usex multicall 1 0)
-               STATIC=$(usex static 1 0)
-       )
-}
-
-src_prepare() {
-       epatch "${FILESDIR}"/${PN}-0.46-dbscp.patch
-       sed \
-               -e '/SFTPSERVER_PATH/s:".*":"/usr/lib/misc/sftp-server":' \
-               default_options.h > localoptions.h || die
-       sed -i \
-               -e '/pam_start/s:sshd:dropbear:' \
-               svr-authpam.c || die
-       restore_config localoptions.h
-}
-
-src_configure() {
-       # XXX: Need to add libtomcrypt to the tree and re-enable this.
-       #       --disable-bundled-libtom
-       # We disable the hardening flags as our compiler already enables them
-       # by default as is appropriate for the target.
-       econf \
-               --disable-harden \
-               $(use_enable zlib) \
-               $(use_enable pam) \
-               $(use_enable !bsdpty openpty) \
-               $(use_enable shadow) \
-               $(use_enable syslog)
-}
-
-src_compile() {
-       set_options
-       emake "${makeopts[@]}" PROGRAMS="${progs[*]}"
-}
-
-src_install() {
-       set_options
-       emake "${makeopts[@]}" PROGRAMS="${progs[*]}" DESTDIR="${D}" install
-       doman *.8
-       newinitd "${FILESDIR}"/dropbear.init.d dropbear
-       newconfd "${FILESDIR}"/dropbear.conf.d dropbear
-       dodoc CHANGES README SMALL MULTI
-
-       # The multi install target does not install the links right.
-       if use multicall ; then
-               cd "${ED}"/usr/bin
-               local x
-               for x in "${progs[@]}" ; do
-                       ln -sf dropbearmulti ${x} || die "ln -s dropbearmulti to ${x} failed"
-               done
-               rm -f dropbear
-               dodir /usr/sbin
-               dosym ../bin/dropbearmulti /usr/sbin/dropbear
-               cd "${S}"
-       fi
-       save_config localoptions.h
-
-       if ! use minimal ; then
-               mv "${ED}"/usr/bin/{,db}scp || die
-       fi
-
-       pamd_mimic system-remote-login dropbear auth account password session
-}
-
-pkg_preinst() {
-       enewgroup sshd 22
-       enewuser sshd 22 -1 /var/empty sshd
-}