sys-apps/checkpolicy: update live ebuild
authorJason Zaman <perfinion@gentoo.org>
Thu, 23 Feb 2017 07:26:10 +0000 (15:26 +0800)
committerJason Zaman <perfinion@gentoo.org>
Thu, 23 Feb 2017 11:14:26 +0000 (19:14 +0800)
need to pass the path to libsepol.a

Package-Manager: portage-2.3.3

sys-apps/checkpolicy/checkpolicy-9999.ebuild

index ae94993763f90a085182772963862b9f3fec55b4..f27b7d320b71ba5ad5a87c27c603edc68be60830 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -37,11 +37,16 @@ DEPEND=">=sys-libs/libsepol-${SEPOL_VER}
 RDEPEND=">=sys-libs/libsemanage-${SEMNG_VER}"
 
 src_compile() {
-       emake CC="$(tc-getCC)" YACC="bison -y" LIBDIR="\$(PREFIX)/$(get_libdir)"
+       emake \
+               CC="$(tc-getCC)" \
+               YACC="bison -y" \
+               LIBDIR="\$(PREFIX)/$(get_libdir)"
 }
 
 src_install() {
-       emake DESTDIR="${D}" install
+       emake DESTDIR="${D}" \
+               LIBSEPOLA="/usr/$(get_libdir)/libsepol.a" \
+               install
 
        if use debug; then
                dobin "${S}/test/dismod"