app-vim/gundo: update to EAPI 7 and drop python2 support
authorTim Harder <radhermit@gentoo.org>
Mon, 13 Jan 2020 02:44:29 +0000 (19:44 -0700)
committerTim Harder <radhermit@gentoo.org>
Mon, 13 Jan 2020 02:46:07 +0000 (19:46 -0700)
Signed-off-by: Tim Harder <radhermit@gentoo.org>
app-vim/gundo/files/gundo-2.6.2-python3.patch [new file with mode: 0644]
app-vim/gundo/gundo-2.6.2-r1.ebuild [new file with mode: 0644]

diff --git a/app-vim/gundo/files/gundo-2.6.2-python3.patch b/app-vim/gundo/files/gundo-2.6.2-python3.patch
new file mode 100644 (file)
index 0000000..89b7706
--- /dev/null
@@ -0,0 +1,13 @@
+Force defaulting to python3.
+
+--- sjl-gundo.vim-6918f8da3839/autoload/gundo.vim
++++ sjl-gundo.vim-6918f8da3839/autoload/gundo.vim
+@@ -44,7 +44,7 @@
+     let g:gundo_close_on_revert = 0
+ endif"}}}
+ if !exists("g:gundo_prefer_python3")"{{{
+-    let g:gundo_prefer_python3 = 0
++    let g:gundo_prefer_python3 = 1
+ endif"}}}
+ if !exists("g:gundo_auto_preview")"{{{
+     let g:gundo_auto_preview = 1
diff --git a/app-vim/gundo/gundo-2.6.2-r1.ebuild b/app-vim/gundo/gundo-2.6.2-r1.ebuild
new file mode 100644 (file)
index 0000000..3140f0d
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit vim-plugin python-single-r1 vcs-snapshot
+
+DESCRIPTION="vim plugin: visualize your vim undo tree"
+HOMEPAGE="https://sjl.bitbucket.io/gundo.vim/"
+SRC_URI="https://bitbucket.org/sjl/gundo.vim/get/v${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+       || (
+               app-editors/vim[python,${PYTHON_USEDEP}]
+               app-editors/gvim[python,${PYTHON_USEDEP}]
+       )
+       ${PYTHON_DEPS}"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+PATCHES=( "${FILESDIR}"/${P}-python3.patch )
+
+src_prepare() {
+       rm -r .gitignore .hg* package.sh README* site tests || die
+       default
+}