net-libs/nghttp2: Bump to version 1.39.1
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 12 Jun 2019 08:01:48 +0000 (10:01 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 12 Jun 2019 08:47:37 +0000 (10:47 +0200)
Closes: https://bugs.gentoo.org/687902
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-libs/nghttp2/Manifest
net-libs/nghttp2/nghttp2-1.39.1.ebuild [new file with mode: 0644]

index ef443b88500769664871e9651e70320e5cabcb3c..258178fea59116b49d7b40de39e842292749049d 100644 (file)
@@ -2,3 +2,4 @@ DIST nghttp2-1.33.0.tar.xz 1554776 BLAKE2B 1b995d6385188423acbcd7c8b3a626a622270
 DIST nghttp2-1.37.0.tar.xz 1628248 BLAKE2B ed5cdfda44b4e38a03d92352520eb765cc1da99080e0cd3e9d663efd5ef2ff219c6ccdbc16cfde001a8377afc796acef250913e1eb422ae2cac2eb95b8f98089 SHA512 67a4b9df3f7f0edad719011fa289d9aa9ef04f31ef3ccf826b861c8830ed24e0743a33b54ab66d198fec7edbf723852b38a2007b335d7f566f702f4b02297b0f
 DIST nghttp2-1.38.0-unbundle_http_parser.patch.xz 2616 BLAKE2B 3f15154d33f32c91aad87f23f56d761501e19e0b53b99d4df720f9e04d6d9c49a52118acbe3da87f8585c2b71b7b430ef60fc33465605f3bf9933635aabb924d SHA512 1b4377b34cf6428164011be9fc86efdd7ab8d3443edf197c45768beea0f843084a842c4cb2abc5179d6036ec99174557e06344ce67a07d98992de64d99faf3a6
 DIST nghttp2-1.38.0.tar.xz 1628356 BLAKE2B 0568d4ac5c1e5e6d7adf762815836502524d59fb55c623f344a8427638407a19447fe1a7753142aa205898f7bda6ebce8ef6f4d85edc6da98ffa98b83d4e363e SHA512 e432d52bcf77379ed5c10ceafb587ec8d66c56bb728cda56487b237cbab1d0073689624419ed306162dab3a51b91cfe0f59cb173b5d81346e2b6d0abd56635bc
+DIST nghttp2-1.39.1.tar.xz 1634512 BLAKE2B 66444de067200a7dd66f162c22fd258471d336b1ba02f579a675b5d9dfcbf1600fcfb92a37797842a0482bd0f5c850008508d3d41f7afddc47f7c9330fb34b43 SHA512 36558ed03c59086086abbf144ec7c54c60de3fea00a9ea594feea7186a779781cbb66a08c9b34265892dea382b42b875f551e85331cfa0086e357f9b27b919fa
diff --git a/net-libs/nghttp2/nghttp2-1.39.1.ebuild b/net-libs/nghttp2/nghttp2-1.39.1.ebuild
new file mode 100644 (file)
index 0000000..970e71d
--- /dev/null
@@ -0,0 +1,78 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+SSL_DEPEND="
+       !libressl? ( >=dev-libs/openssl-1.0.2:0=[-bindist,${MULTILIB_USEDEP}] )
+       libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
+"
+RDEPEND="
+       cxx? (
+               ${SSL_DEPEND}
+               dev-libs/boost:=[${MULTILIB_USEDEP},threads]
+       )
+       hpack-tools? (
+               >=dev-libs/jansson-2.5
+               >=net-libs/http-parser-2.9.1:=
+       )
+       jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
+       utils? (
+               ${SSL_DEPEND}
+               >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+               >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+               net-dns/c-ares:=[${MULTILIB_USEDEP}]
+       )
+       xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+multilib_src_configure() {
+       local myeconfargs=(
+               --disable-examples
+               --disable-failmalloc
+               --disable-python-bindings
+               --disable-werror
+               --without-cython
+               $(use_enable cxx asio-lib)
+               $(use_enable debug)
+               $(multilib_native_use_enable hpack-tools)
+               $(use_enable static-libs static)
+               $(use_enable threads)
+               $(multilib_native_use_enable utils app)
+               $(multilib_native_use_with jemalloc)
+               $(multilib_native_use_with xml libxml2)
+       )
+       ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+       if ! use static-libs ; then
+               find "${ED}"/usr -name '*.la' -delete || die
+       fi
+}