dev-python/python-stdnum: Version bumps
authorCédric Krier <cedk@gentoo.org>
Sun, 8 Oct 2017 16:39:14 +0000 (18:39 +0200)
committerCédric Krier <cedk@gentoo.org>
Sun, 8 Oct 2017 16:39:14 +0000 (18:39 +0200)
Package-Manager: Portage-2.3.8, Repoman-2.3.1

dev-python/python-stdnum/Manifest
dev-python/python-stdnum/python-stdnum-1.7.ebuild [new file with mode: 0644]

index 2554054fc8e471e6409bb7dce315c3a8182474b0..e5a9f409daa28674ee149a9fd4f3f6b3a0a13309 100644 (file)
@@ -1,2 +1,3 @@
 DIST python-stdnum-1.5.tar.gz 268416 SHA256 10fe3db303aec532057484668ca9a4f421c2e5b3b1caee670b26b047bcbc737e SHA512 8d6394d7039fc5a2e3785eb95ef1793038ae75443224fc5af7f1cae2cb575c2f4e5451bd9668304ba95d3ee3f87dc0103ccf6c35837220f9729cbe1a3e13f656 WHIRLPOOL 530d5b5b5f9ca3d1d6b0a9c2078d90112180724ec05750be1e5d30990cf1fff067e0342c221bbb52fdfc902ab1efc09adb1ab7fce2833d35368e53ae16de8ec1
 DIST python-stdnum-1.6.tar.gz 399518 SHA256 157a0aef01b1e846ddd11252dc516637da6b3347e32f0130825b7fae1d8b4655 SHA512 dc2fba2563e4de658a09b7afc7d0d663f21b5528da9061f126d581e8deb2a88569c83304bde834c0da376dc65ee09274aed82d55abb60b0fe0a181e1b5cfe88f WHIRLPOOL 2bd6203adde32bda1c2971d743fcb9db02c49a65c944e57a3d58d4ca7f3e16c08d82ee018208aff45e1e7c7c347580396aa02fbb2dc0f7cc7608c3b26fb83d9f
+DIST python-stdnum-1.7.tar.gz 411134 SHA256 987c25e1047e8742131bcf29dac7a406987adb1463465749e2daaba8cb19d264 SHA512 323f5e37087e95143eb59345c4ddb5fb1529a136c234c8e9c957cf9914984e758b256facbfbc5de379000b8939460ea25e8105428d67f7052a23676c334a002a WHIRLPOOL 8cff46c9f7406f3f8783ab522c14a3fe43d7469759eccd99dfe1ffe900313c687d378d14e99110219b51783d7786d0efa2df8a66cb52158d8943214eb0dfcd40
diff --git a/dev-python/python-stdnum/python-stdnum-1.7.ebuild b/dev-python/python-stdnum/python-stdnum-1.7.ebuild
new file mode 100644 (file)
index 0000000..6bb1b06
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="http://arthurdejong.org/python-stdnum/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vies test"
+
+RDEPEND="vies? ( dev-python/suds )"
+DEPEND="${DEPEND}
+       dev-python/setuptools
+       test? ( dev-python/nose )"
+
+DOCS=( ChangeLog NEWS README )
+
+python_test() {
+       nosetests || die
+}