app-i18n/pology: Sync with 9999, disable epydoc
authorAndreas Sturmlechner <asturm@gentoo.org>
Tue, 28 Jan 2020 22:47:37 +0000 (23:47 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Tue, 28 Jan 2020 22:49:58 +0000 (23:49 +0100)
Closes: https://bugs.gentoo.org/707036
Package-Manager: Portage-2.3.86, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-i18n/pology/pology-0.12-r1.ebuild [new file with mode: 0644]

diff --git a/app-i18n/pology/pology-0.12-r1.ebuild b/app-i18n/pology/pology-0.12-r1.ebuild
new file mode 100644 (file)
index 0000000..da1015d
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit bash-completion-r1 cmake kde.org python-single-r1
+
+DESCRIPTION="A framework for custom processing of PO files"
+HOMEPAGE="http://pology.nedohodnik.net"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+       SRC_URI="http://pology.nedohodnik.net/release/${P}.tar.bz2"
+       KEYWORDS="amd64 x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+       app-text/docbook-xsl-stylesheets
+       app-text/docbook-xml-dtd:4.5
+"
+RDEPEND="${PYTHON_DEPS}
+       dev-libs/libxml2
+       dev-libs/libxslt
+       dev-python/dbus-python[${PYTHON_USEDEP}]
+       sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+
+# Magic on python parsing makes it impossible to make it parallel safe
+MAKEOPTS+=" -j1"
+
+src_prepare() {
+       cmake_src_prepare
+       sed -e "/DOC_INSTALL_DIR/s/^/#DONT/" -i CMakeLists.txt || die
+       python_fix_shebang .
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DDOC_INSTALL_DIR="${EPREFIX}"/usr/share/doc/${PF}
+               -DCMAKE_DISABLE_FIND_PACKAGE_Epydoc=ON
+       )
+       cmake_src_configure
+}
+
+src_install() {
+       cmake_src_install
+       python_optimize
+
+       dosym ../../../pology/syntax/kate/synder.xml /usr/share/apps/katepart/syntax/synder.xml
+
+       newbashcomp "${ED}"/usr/share/pology/completion/bash/pology posieve
+       bashcomp_alias {posieve,poediff}{,.py}
+
+       elog "You should also consider following packages to install:"
+       elog "    app-text/aspell"
+       elog "    app-text/hunspell"
+       elog "    dev-vcs/git"
+       elog "    dev-vcs/subversion"
+       elog "    sci-misc/apertium"
+}