dev-libs/libspt: update patches
authorAkinori Hattori <hattya@gentoo.org>
Sat, 8 Jul 2017 08:17:25 +0000 (17:17 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Sat, 8 Jul 2017 08:17:25 +0000 (17:17 +0900)
Package-Manager: Portage-2.3.6, Repoman-2.3.1

dev-libs/libspt/files/libspt-gentoo.patch [new file with mode: 0644]
dev-libs/libspt/files/libspt-werror.patch [deleted file]
dev-libs/libspt/libspt-1.1-r2.ebuild

diff --git a/dev-libs/libspt/files/libspt-gentoo.patch b/dev-libs/libspt/files/libspt-gentoo.patch
new file mode 100644 (file)
index 0000000..f6c709b
--- /dev/null
@@ -0,0 +1,29 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -9,7 +9,7 @@
+ libexecdir = @libexecdir@
+ includedir = @includedir@
+ #docdir = $(prefix)/doc
+-mandir = $(prefix)/man
++mandir = @mandir@
+ EXEEXT = @EXEEXT@
+@@ -29,7 +29,7 @@
+ INCLUDES = -I.
+ DEFS = @DEFS@
+ CC = @CC@
+-COMMONCFLAGS = -Wall -g -Werror -pipe
++COMMONCFLAGS = -Wall -g -pipe
+ CFLAGS = $(COMMONCFLAGS) @CFLAGS@
+ INSTALL = $(LIBTOOL) --mode=install @INSTALL@
+ INSTALL_DATA = $(LIBTOOL) --mode=install @INSTALL@ -m 644
+@@ -48,7 +48,7 @@
+ AGENTOBJS = sptagent.o sptconn.$lo cfuncs.$lo
+ LIBOBJS = libspt.$lo sptconn.$lo cfuncs.$lo error.$lo utilapi.$lo termios.$lo
+ OBJS = test.o $(LIBOBJS)
+-AGENT_MODE = -m 4755 -o root -g wheel
++AGENT_MODE =
+ .SUFFIXES: .c .o .cc .lo
+ .c.lo:
diff --git a/dev-libs/libspt/files/libspt-werror.patch b/dev-libs/libspt/files/libspt-werror.patch
deleted file mode 100644 (file)
index 6190ea5..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in        2003-12-07 06:42:15.000000000 +0000
-+++ Makefile.in        2009-03-10 21:09:43.000000000 +0000
-@@ -29,7 +29,7 @@
- INCLUDES = -I.
- DEFS = @DEFS@
- CC = @CC@
--COMMONCFLAGS = -Wall -g -Werror -pipe
-+COMMONCFLAGS = -Wall -g -pipe
- CFLAGS = $(COMMONCFLAGS) @CFLAGS@
- INSTALL = $(LIBTOOL) --mode=install @INSTALL@
- INSTALL_DATA = $(LIBTOOL) --mode=install @INSTALL@ -m 644
index 255689643e51281958ff3ceb1d39886d07b93bc6..cd153e952273f111ac08dc42b5fb14686675127f 100644 (file)
@@ -1,7 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="2"
+
 inherit base
 
 DESCRIPTION="Library for handling root privilege"
@@ -12,13 +13,10 @@ LICENSE="BSD-2"
 SLOT="0"
 KEYWORDS="alpha amd64 ppc x86"
 IUSE=""
-
 RESTRICT="test"
 
 src_prepare() {
-       epatch \
-               "${FILESDIR}/libspt-werror.patch" \
-               "${FILESDIR}/${P}-gentoo.patch"
+       epatch "${FILESDIR}/${PN}-gentoo.patch"
 }
 
 src_install() {