net-libs/ntirpc: Bump to version 3.0
authorLars Wendler <polynomial-c@gentoo.org>
Fri, 13 Dec 2019 11:01:56 +0000 (12:01 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Fri, 13 Dec 2019 11:04:48 +0000 (12:04 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-libs/ntirpc/Manifest
net-libs/ntirpc/ntirpc-3.0.ebuild [new file with mode: 0644]

index eb111130863d8fba399474954820b0b0eaeae53b..da54db05524aadc8afc9dee9fd02b0d77157dbde 100644 (file)
@@ -1,2 +1,3 @@
 DIST ntirpc-1.7.1.tar.gz 373327 BLAKE2B 55d71932e35b844e382409593b5dead30246d0cbaa27d3d49ad94d09435acb8abb34b945ba90ab7ba9733a955b4184ad839ba202aa82f97eeecbcc502cb88bf0 SHA512 9a98d83db94b4775940584cd08a1105b79263412d44309f91d1e86c609e6d56a482ac239efaaa73ccc1c2f4cabb8b597ccb8931514f33b8b2fd5c2a11b731106
 DIST ntirpc-1.7.4.tar.gz 373897 BLAKE2B 7354c5d6114947c8d66dcbc4fb933ab38237dd70eeb318278a658946fa4ec354bcaf7e90ac210f39f76b6d8e60f865c0c63ecbf7cbd8ee1e8defa0d7622cfb51 SHA512 076d789edc3fdf0ddb75437196b72b1aef78780d579ae4db0bcc116a1a92ac861fc77e1611070f2d3df003bfec7883ab20653a3c2f2255c685aaed8e7c22ce0f
+DIST ntirpc-3.0.tar.gz 386738 BLAKE2B 123c8f31ea532f6a01b4544d4f19d503c6e44ec8f3923f3f053f1ccc2ff5c5dc62da6464373b25a1881f69749a4c62395838be4451f3281ed9e7446eb8380255 SHA512 a7e9fdfcdaa2e85d4631094874bd72dce6c2e93924f6099f6bc20c98a1792839559ffb028b100aa3c5ec0140c10e090b32155439846276f918e9ba017271e14b
diff --git a/net-libs/ntirpc/ntirpc-3.0.ebuild b/net-libs/ntirpc/ntirpc-3.0.ebuild
new file mode 100644 (file)
index 0000000..f492c29
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
+HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gssapi rdma"
+
+# Since the GSS option only controls some extra files to be enabled,
+# there's nothing to list in the depend string for it.
+RDEPEND="
+       app-crypt/mit-krb5
+       dev-libs/userspace-rcu
+       net-libs/libnsl
+       rdma? ( sys-fabric/librdmacm )
+"
+DEPEND="
+       ${RDEPEND}
+"
+
+multilib_src_configure() {
+       local mycmakeargs=(
+               -DUSE_GSS="$(usex gssapi)"
+               -DUSE_RPC_RDMA="$(usex rdma)"
+       )
+       cmake-utils_src_configure
+}