www-client/luakit: update live ebuild
authorKristopher Keller <kristopher004@gmail.com>
Sat, 28 Mar 2020 22:26:23 +0000 (16:26 -0600)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 1 Apr 2020 14:37:33 +0000 (17:37 +0300)
Add prefix to emake so luakit can find modules and fix various repoman
warnings.

  - Bump copyright
  - Bump to EAPI 7
  - Inherit xdg-utils
  - Use https for repo uri
  - Add PREFIX to emake in compile phase
  - Edit Makefile to install uncompressed man page
  - Add xdg functions for desktop file

Closes: https://bugs.gentoo.org/715184
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Kristopher Keller <kristopher004@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/15157
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
www-client/luakit/luakit-9999.ebuild

index fb0f02b0108768774aaffcce4eb25baa794cbb5c..3f617a46a60ca4e25723d6cbabbe9896888834ff 100644 (file)
@@ -1,16 +1,16 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-inherit toolchain-funcs
+inherit toolchain-funcs xdg-utils
 
 DESCRIPTION="A fast, light, simple to use micro-browser using WebKit and Lua"
 HOMEPAGE="https://luakit.github.io/luakit"
 
 if [[ ${PV} == 9999 ]]; then
        inherit git-r3
-       EGIT_REPO_URI="git://github.com/luakit/luakit.git"
+       EGIT_REPO_URI="https://github.com/luakit/luakit.git"
 else
        SRC_URI="https://github.com/luakit/luakit/archive/${PV}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="~amd64"
@@ -43,6 +43,7 @@ src_compile() {
                CC=$(tc-getCC) \
                LUA_PKG_NAME=$(usex luajit 'luajit' 'lua') \
                LUA_BIN_NAME=$(usex luajit 'luajit' 'lua') \
+               PREFIX="${EPREFIX}/usr" \
                all
 
        use doc && emake doc
@@ -55,6 +56,8 @@ src_test() {
 }
 
 src_install() {
+       sed -i 's/install -m644 luakit.1.gz/install -m644 luakit.1/g' Makefile || die
+
        emake \
                DESTDIR="${D}" \
                PREFIX="${EPREFIX}/usr" \
@@ -66,3 +69,9 @@ src_install() {
 
        use doc && dodoc -r doc/html
 }
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}