dev-python/ply: clear PYTHONDONTWRITEBYTECODE for tests
authorMike Gilbert <floppym@gentoo.org>
Sun, 22 Jan 2017 02:12:23 +0000 (21:12 -0500)
committerMike Gilbert <floppym@gentoo.org>
Sun, 22 Jan 2017 02:13:35 +0000 (21:13 -0500)
Bug: https://bugs.gentoo.org/458648
Package-Manager: Portage-2.3.3_p32, Repoman-2.3.1_p25

dev-python/ply/ply-3.6-r1.ebuild
dev-python/ply/ply-3.8.ebuild
dev-python/ply/ply-3.9.ebuild

index b9c8333cada0b7ab4ae46bdb7a41c0ef7de26e41..a3436a4ed3adb9151bd3148a4a22652e9fa30dc6 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -19,9 +19,6 @@ IUSE="examples"
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 RDEPEND=""
 
-# See bug #458648 for reference
-RESTRICT="test"
-
 DOCS=( ANNOUNCE CHANGES TODO )
 PATCHES=(
        "${FILESDIR}/3.6-lextab-None.patch"
@@ -32,6 +29,9 @@ python_test() {
        cp -r -l test "${BUILD_DIR}"/ || die
        cd "${BUILD_DIR}"/test || die
 
+       # Checks for pyc/pyo files
+       local -x PYTHONDONTWRITEBYTECODE=
+
        local t
        for t in testlex.py testyacc.py; do
                "${PYTHON}" "${t}" || die "${t} fails with ${EPYTHON}"
index 9f368cb637bed11b8edb5123915d6d9375f76ed3..35f8116dcf7ecde0552dbcd4e622118024fb85ac 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -20,9 +20,6 @@ IUSE="examples"
 RDEPEND=""
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 
-# See bug #458648 for reference
-RESTRICT="test"
-
 DOCS=( ANNOUNCE CHANGES TODO )
 
 PATCHES=( "${FILESDIR}/3.6-picklefile-IOError.patch" )
@@ -31,6 +28,9 @@ python_test() {
        cp -r -l test "${BUILD_DIR}"/ || die
        cd "${BUILD_DIR}"/test || die
 
+       # Checks for pyc/pyo files
+       local -x PYTHONDONTWRITEBYTECODE=
+
        local t
        for t in testlex.py testyacc.py; do
                "${PYTHON}" "${t}" || die "${t} fails with ${EPYTHON}"
index 8c335d71358f818565296e9403a939b52b0b3465..92d21999fdaf5f0c285f0160077c87c367bf0fb4 100644 (file)
@@ -20,9 +20,6 @@ IUSE="examples"
 RDEPEND=""
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 
-# See bug #458648 for reference
-RESTRICT="test"
-
 DOCS=( ANNOUNCE CHANGES TODO )
 
 PATCHES=( "${FILESDIR}/3.6-picklefile-IOError.patch" )
@@ -31,6 +28,9 @@ python_test() {
        cp -r -l test "${BUILD_DIR}"/ || die
        cd "${BUILD_DIR}"/test || die
 
+       # Checks for pyc/pyo files
+       local -x PYTHONDONTWRITEBYTECODE=
+
        local t
        for t in testlex.py testyacc.py; do
                "${PYTHON}" "${t}" || die "${t} fails with ${EPYTHON}"