dev-qt/qtwebkit: Fix build against ICU-65
authorAndreas Sturmlechner <asturm@gentoo.org>
Tue, 22 Oct 2019 19:46:14 +0000 (21:46 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 23 Oct 2019 23:32:20 +0000 (01:32 +0200)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20190629-icu-65.patch [new file with mode: 0644]
dev-qt/qtwebkit/qtwebkit-5.212.0_pre20190629.ebuild

diff --git a/dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20190629-icu-65.patch b/dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20190629-icu-65.patch
new file mode 100644 (file)
index 0000000..1891f73
--- /dev/null
@@ -0,0 +1,55 @@
+From dc02ec4080010e33b737db6491d71d6bb961a77d Mon Sep 17 00:00:00 2001
+From: "commit-queue@webkit.org"
+ <commit-queue@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
+Date: Fri, 4 Oct 2019 21:51:37 +0000
+Subject: [PATCH] Fix build with icu 65.1
+ https://bugs.webkit.org/show_bug.cgi?id=202600
+
+Patch by Heiko Becker <heirecka@exherbo.org> on 2019-10-04
+Reviewed by Konstantin Tokarev.
+
+Source/WebCore:
+
+* dom/Document.cpp:
+(WebCore::isValidNameNonASCII):
+(WebCore::Document::parseQualifiedName):
+
+Source/WTF:
+
+* wtf/URLHelpers.cpp:
+(WTF::URLHelpers::allCharactersInIDNScriptWhiteList):
+
+Change-Id: I1b087322cbae43fbe155facdf933717ac8569b6c
+git-svn-id: http://svn.webkit.org/repository/webkit/trunk@250747 268f45cc-cd09-0410-ab3c-d52691b4dbfc
+---
+ Source/WebCore/dom/Document.cpp |  6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Source/WebCore/dom/Document.cpp b/Source/WebCore/dom/Document.cpp
+index 1bca2d0a66f8..19355f166019 100644
+--- a/Source/WebCore/dom/Document.cpp
++++ b/Source/WebCore/dom/Document.cpp
+@@ -4407,12 +4407,12 @@ static bool isValidNameNonASCII(const UChar* characters, unsigned length)
+     unsigned i = 0;
+     UChar32 c;
+-    U16_NEXT(characters, i, length, c)
++    U16_NEXT(characters, i, length, c);
+     if (!isValidNameStart(c))
+         return false;
+     while (i < length) {
+-        U16_NEXT(characters, i, length, c)
++        U16_NEXT(characters, i, length, c);
+         if (!isValidNamePart(c))
+             return false;
+     }
+@@ -4474,7 +4474,7 @@ bool Document::parseQualifiedName(const String& qualifiedName, String& prefix, S
+     for (unsigned i = 0; i < length;) {
+         UChar32 c;
+-        U16_NEXT(qualifiedName, i, length, c)
++        U16_NEXT(qualifiedName, i, length, c);
+         if (c == ':') {
+             if (sawColon) {
+                 ec = NAMESPACE_ERR;
index 025efa83545996c058f0ba66d042a9874cd9c3e1..bcf7027ae698e895a8d66a118e6346af4aed9e5d 100644 (file)
@@ -77,6 +77,8 @@ S="${WORKDIR}/${MY_P}"
 
 CHECKREQS_DISK_BUILD="16G" # bug 417307
 
+PATCHES=( "${FILESDIR}/${P}-icu-65.patch" )
+
 _check_reqs() {
        if [[ ${MERGE_TYPE} != binary ]] && is-flagq "-g*" && ! is-flagq "-g*0"; then
                einfo "Checking for sufficient disk space to build ${PN} with debugging flags"