net-proxy/pingtunnel: Use proper POSIX #include's
authorDavid Seifert <soap@gentoo.org>
Sat, 21 Mar 2020 14:26:50 +0000 (15:26 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 21 Mar 2020 14:26:50 +0000 (15:26 +0100)
Closes: https://bugs.gentoo.org/713758
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: David Seifert <soap@gentoo.org>
net-proxy/pingtunnel/files/pingtunnel-0.72-musl.patch [new file with mode: 0644]
net-proxy/pingtunnel/pingtunnel-0.72.ebuild

diff --git a/net-proxy/pingtunnel/files/pingtunnel-0.72-musl.patch b/net-proxy/pingtunnel/files/pingtunnel-0.72-musl.patch
new file mode 100644 (file)
index 0000000..cf42136
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/ptunnel.h
++++ b/ptunnel.h
+@@ -45,7 +45,6 @@
+ //    Includes
+ #ifndef WIN32
+-      #include        <sys/unistd.h>
+       #include        <sys/types.h>
+       #include        <sys/socket.h>
+       #include        <netinet/in.h>
index cc137990d13830ca5eab4529b6fb2b79e2e1ae31..0536913f7464cf32de022b32ee897d7bb9e05254 100644 (file)
@@ -21,7 +21,10 @@ DEPEND="${RDEPEND}"
 
 S="${WORKDIR}"/PingTunnel
 
-PATCHES=( "${FILESDIR}"/${P}_makefile.patch )
+PATCHES=(
+       "${FILESDIR}"/${P}_makefile.patch
+       "${FILESDIR}"/${P}-musl.patch
+)
 HTML_DOCS=( web/. )
 
 src_configure() {